0

I have no brakes. I have bled the brakes, changed the pads and calipers, brake hose. The front driver side bled with no problems but the passenger won't. What else could it be? I've also replaced the valve pressure. The car is a 1991 Toyota Celica GT convertible.

  • Welcome to Motor Vehicle Maintenance & Repair! When you say the passenger side won't, what exactly is it doing (or not doing)? – Pᴀᴜʟsᴛᴇʀ2 Jul 8 '18 at 23:27
1

There are two possibilities which will depend on if the car is an ABS equipped model or not.

If the car is a non-ABS model, you'll almost certainly have diagonally split brake circuit whereby the near-side rear and off-side front brakes are on the same circuit. Typically you would bleed the system by opening the nipple furthest from the master cylinder first; i.e. one of the rear calipers. Bleed the car sitting on the ground so that any brake bias valve doesn't isolate the rear calipers.

If the car is ABS equipped you may find there is a vehicle specific procedure to go through in the event that air has entered the ABS control module. This can happen if the fluid level in the master cylinder drops below a certain point during the bleeding process. If this is the case, you'll likely need the attach the car to a scan tool to put the ABS pump in a state where it can be bled.

Finally, how are you bleeding the brakes? I've personally found a "one man" bleed kit that uses air pressure differences to force fluid through the system is far more effective than the older method of opening a bleed nipple and pumping the pedal.

Good luck.

0

Can you elaborate a bit more on "no brakes". What symptoms are you having? What kind of feedback are you getting from the brake pedal? Were your brakes working before?

Since it sounds like you replace parts of the hydraulic system, have you made sure that there is no air stuck in the brake line? Air is compressible so any air stuck in the brake line would cause a "spongy" brake feel and may not provide enough force to push the piston.

Also, I would check that your brake hoses are connected properly and you're not leaking brake fluid everywhere.

0

it can't hurt to ask the obvious question: did you make sure there's fluid in the reservior? Some cars diagonally split have two separate reservoirs for left and right. I would try this though: make sure reservoir is full and open left bleeder then pump the petal until fluid starts coming out the bleeder. If this never happens and the petal never comes up, your master cylinder is bad. If you get a hard petal after a while you have a clog somewhere (possibly the bleeder valve which you can eliminate by removing completely).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.