3

a friend of mine is selling a Mercedes-Benz C200 CDI W204 facelift from 2012(with those fancy ILS headlights). The car is very cheap compared to others on the market because it has been in a crash on the left side (driver side).My friend took it to a mechanic which did a mediocre job, only changing the body panels nicely.I took the car to inspect it, as i am thinking of buying it. Mechanically, the car drives exceptionally at 70000km being practically new and had sat in the shop for 2 years. The left healight had it's connector severed off. Thus, i bought a plug and wired it based on the colors. Now the problems start:

  1. The unaffected side turning signal turns on(literally stays on, not flashing) when the wheel is slightly turned to the right.
  2. If I turn on the hazards, the left side doesn't turn on at all(or sometimes flashes very quick) and the right side stays on, not being synched with the lights on the mirrors and the back.
  3. If I switch on the ignition, both of the V Led thingys turn on as well as the fog lights(if the button is pressed), but as soon i turn on the engine the affected site LED turn off, and the Xenon on the opposite side turns on.
  4. If i rotate the key to turn of the engine, it takes a while for it to turn of (half a second to a second after "removing" the ignition) and i don't know if it is normal.
  5. If I press the fog lights button, the sign in the dashboard appears, but the actual fog lights turn off and vice versa.
  6. When I lock the car, the drivers side turning light flashes furiously.
  7. I tried to put a scanner on the car (a regular one, not the fancy Mercedes one) it said that all the car's modules aren't equipped (engine module, transmission module, fuel pump, sound etc).

The rest of the car works as expected, the infotainment system has no issues: bluetooth, screen, speakers, buttons and such.Pretty much, everything works from the windshield. Also, there are a lot of plugs which i don't know where they go. Thank you for reading my story and problem and I hope an electrician will help me with my problem!

  • Steer clear, this could take hours to solve... – Solar Mike May 22 '18 at 19:31
  • 2
    Tell them you may buy if they correct the problems first. – Moab May 22 '18 at 19:50
  • I was thinking it would be the front SAM of the car, as it has been sitting in a shop for 2 years. Who know if it has been rained on or something, maybe it had a short and fried the front computer?The rest of the car(with its computers) works perfectly. – TakeDown May 23 '18 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.