1

Has anyone had a problem with a 2004 Nissan Altima 3.5L having the alternator go bad and then then engine start running really bad multiple misfire and getting pressure in the crank case aka blow by.

  • And engine won't rev out like its in limp mode – Marc Taliaferro May 10 '18 at 17:53
  • Sounds like you may have multiple issues going on. Can you get the codes read and list them here? That will help a lot for us to be able to assist you. – CharlieRB May 10 '18 at 18:17
  • The car was running perfect!!!! I did the throttle relearn and put a new battery disconnected the intake from the throttle body and it started better but still run bad. And pcv is new – Marc Taliaferro May 11 '18 at 0:04
  • The thing i am really worried about is that it has alot of blow by. I take off the oil cap and it runs a little better but is puffing out pressure from crankcase. The pcv is new. I just wonder if its the rings that are bad and how just with the turn of the key pretty much or is the valve cover clogged on the inside where the pcv goes or is it because the Alternator is bad and the engine isnt running right because of not enough voltage. I just cant believe that it went from running beautifully to random misfires and not being able to rev passed 2000 rpm and has so much pressure in crankcase. – Marc Taliaferro May 11 '18 at 0:20
  • If you had a shop do the work, take it back. If you did the work, double check that you have everything connected correctly. A missed connector can cause all kinds of problems. – CharlieRB May 11 '18 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.