2

I have a 1993 Fiat Panda 1.0 i.e. (gasoline) with single injector. Last year it started to present a very specific issue: from time to time (but basically now it happens every time I drive the car) it "gives gas" by itself for some seconds, usually noticed when idling.

The engine can be warm or cold, it does not matter. Also, the minimum rpm never drops below the factory correct value: it only goes up. The fuel consumption does not appear to be affected at all (I keep track all).

For example, at the red light when idling and without touching the gas pedal, the engine in some cases starts "hunting", oscillating between the usual minimum rpm and an higher value like I was giving rpetitive pushes to the pedal, or, more frequently, the engine start keeping a quite high rpm (I estimate 2000-3000 rpm), VERY constant, before dropping back to normal.

When this happens, pressing repetitively the gas does not help: when I start touching the pedal the rpm goes down a little (I mean for half second), then picks up again following my foot (it increases further). Sometimes it's even worse and the gas I give just moves the "minimum" to an even higher rpm, even after releasing the pedal.

Sometimes I'm not idling but I'm driving (highway, city, it doesn't matter) and I notice that when I release the pedal the engine brake is very weak. I engage the clutch and I can confirm it's idling at high rpm. This can be dangerous, the brakes have to do more work.

The issue disappears by itself within 10-20 seconds, usually, but I have the feeling that when I give a lot of gas (that means I'm driving) it gets shorter.

Another example: once the issue was showing up and I had to give full gas. After the usual delay the car lost power, going back to the "normal" power.

It seems like somewhere additional air is let in. Am I correct?

I tried to spray brake cleaner in the engine bay (very far from the air intake) and I noticed a reproducible increase in rpm, but very minimum. I don't think there is a leak. I also tried moving the fuel lines and air ducts (quite old) in case there was a crack, but no effect.

The butterfly looks very clean.

The stepper motor for the bypass air is fixed (very tightly) with two screws, one of which has a destroyed head, so I couldn't take it out last time.

What should I focus on, when trying to fix the issue?

  • 1
    To know what kind of car this is and engine it has would go a long way to giving a proper answer here. Knowing the vehicle could tell us if this is a common issue or if we should be telling you to look somewhere else. Without it, we can only give you generic answers to your question. – Pᴀᴜʟsᴛᴇʀ2 Apr 5 '18 at 17:41
  • @Pᴀᴜʟsᴛᴇʀ2 done – FarO Apr 5 '18 at 17:49
1

I'd start by looking for a vacuum leak. It's a common culprit when dealing with a fluctuating idle.

Also, a few notes:

Your "gas pedal" doesn't really control the flow of fuel. It controls the throttle (your butterfly valve). In a modern car, the engine-control computer would look at a few variables, such as air temperature, throttle position, current RPM, etc. and decide how much fuel to inject. On a '93 model with a single injector, I'm not sure how that's accomplished - but the idea is the same. You control the air, the other systems control the gas.

If there's a vacuum leak, then it can act just like you're hitting the pedal as it can introduce additional air into the system - just like what happens when the throttle is opened up.

In a computer-controlled system (again, I'm not sure how this is implemented in older cars), the computer can try to adjust for a lean condition, caused by more air than is optimal, by adjusting fuel delivery. That's one of the benefits of electronic injection, and also the reason for all of the freaking sensors that make repairs and diagnosis such a pain.

  • Well there is a lambda, a vacuum sensor, a temperature sensor, maybe throttle position (I think). The ECU uses them to define the fuel injection. – FarO Apr 5 '18 at 17:49
  • But a vacuum leak that brings the car only for short periods, the periods being alyways within 10-20 seconds? I did the brake cleaner test for that, but it's strange. – FarO Apr 5 '18 at 17:51
  • 1
    @FarO and airflow (MAF), pressure (MAP), etc. It's a mess. – 3Dave Apr 5 '18 at 17:52
  • @FarO ... probably not a leak if it's that regular / periodic. Shrug. :/ – 3Dave Apr 5 '18 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.