2

Recently, my father bought a used 307 (late 2003), the car is good and we all love it.. The previous owner made some hacks on it, that includes a mat color and a touch screen DVD/Radio player with a rear camera.

After some weeks we had some issues:

  • Sometimes it feels that the car have no real power, when on 2nd gear, the speed limit is 30KM/h with 3000RPMs and a huge noise of the roaring engine, on 3rd gear I can reach 50KM/h, and 70KM/h on 4th gear, I always try to not exceed 3000RPMs because it feels scarry with the huge roaring I hear. To have the RPM around 2000 and keeping a quite engine I start going for the 3th gear when I am around 30KM/h and 4th gear when between 50 and 70KM/h. Is what I described normal or I need to check something?
  • Now when I am on 3rd or upper gears and I hit strong the accelerator pedal I have ZERO power change, only a very quick jump of RPMs with no power at all, it is like I was using the clutch, but I am not, however if I keep using the accelerator pedal a little bit in a stable way I can have a speed increase.
  • The DVD/Player screen started to go off after seconds from starting, but it was working well, even the touch sensors were working.. After some days, the DVD player stop working at all, but the screen still show the DVD/player splash screen when the car starts, and the view from the rear camera when I switch to reverse, but only for a second or two. When we 1st got the car I checked the DVD/Player information, it says that it is a wotai 8288t, I am not sure what can cause this issue. PS: The Radio antenna on the roof is missing, so one of my theories that it can be a issue because of rain reach the antenna socket, correct me if this can not be true.
  • This is not a really an issue, but I think I need to ask about it, when I push the lock key in the board it don't close the doors, but I hear them close then open immediately, what can the cause of that?

Thanks in advance.

  • I think you have too many zeros on your RPM. e.g. 3000 not 30000, 2000 not 20000 – HandyHowie Feb 27 '18 at 11:57
  • Sounds like your clutch is slipping. – HandyHowie Feb 27 '18 at 11:58
  • I'll check the clutch asap – elacheche Feb 27 '18 at 16:58
0
  • Sounds like the clutch is worn out and slipping, better have it looked at soon before the car wont move at all.
  • See above
  • Some electrical or software gremlin in an aftermarket Chinese entertainment system. Dont even bother fixing it unless you can somehow find a support website.
  • You have a situation where the central locking system cannot lock the doors, for example because you have a door open. If the central locking system still works when locking the car from the outside then there is no problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.