1

I currently have a problem with accelerating on my uno. When i step on the accelerator the refs go's up but the car wont go forward . I need to accelerate very slowly and evenly to get the car to move. I tried to replace the distributor but it still gives me the same problem when i go uphill i totally have like power loss the car struggles to accelerate. is there a list that i can check and do diagnostics?

2
  • Welcome to the site, Alvin. Does your Fiat have a manual transmission or automatic? When was the last time the engine was serviced (tuned up)? You said the engine revs, but the car won't go. Is that the same thing going uphill? – CharlieRB Feb 13 '18 at 21:11
  • Hi there it is a manual transmission. the last time was about the car was service was about a year ago but it was only a minor – Alvin Godfrey Feb 15 '18 at 19:01
1

Sounds a lot like your clutch has worn out. The engine revs go up but the car will not move that well because the friction material is gone and the clutch is slipping. If its an automatic transmission than possibly the transmission fluid level is very low. If you have to drive it to a repair shop: avoid hills, be easy on the accelerator and use a low gear to strain the drivetrain as little as possible.

1
  • Thank you for the advise. I thought that it might be the clutch as i am also struggling to put the car in certain gears – Alvin Godfrey Feb 15 '18 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.