2

On my Honda CBF 150cc , the Tachometer shows RPM correctly when i'm at a constant speed. But some times when i slow down and accelerate the RPM Needle moves unexpectedly. (say to 0 even i'm at a reasonable speed and suddenly goes way too high where i'm just starting to accelerate). Any ideas why this is happening ?

Update:Its Analogue i think(Traditional one with the Needle and Numbers)

This update was proposed by an anonymous user so I am not sure if it was from the OP.

closed as unclear what you're asking by Jason C, MooseLucifer, Hᴇʀʙɪᴇ, kmarsh, Criggie Aug 12 '16 at 1:33

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Is it an aftermarket tacho? And is it digital or analogue? – Dan Jan 17 '13 at 11:21
  • 2
    By analog I think he is referring to if there is a cable attached to the back of the gauge (middle of the dial) or does it just have wires (digital signal). – Eric Fossum Feb 19 '13 at 0:04
  • I have a needle with numbers tacho on my bike but its digital so we cant be sure if the edit is based on that observation alone – Shobin P May 21 '15 at 5:53
  • It seems that the question implied is why would my tachometer give spurious readings and what might be done to fix it. – dlu Jul 30 '16 at 15:08

Browse other questions tagged or ask your own question.