2

I have a 1984 Ford Coachman C class RV, E 350 460. I just recently replaced the alternator and put in brand new batteries. I am currently stuck and the engine won't even click when I try to turn it on. I also tried jumping it and still, not even a click. I also tried giving the starter a tap and still nothing. What should I be looking for?

  • it also wont pump fuel the engine like the battery is dead – james Dec 7 '17 at 3:11
1
  1. Inspect your battery terminals: loose or corroded connections can prevent the starter from getting enough juice.
  2. Inspect your engine grounds, make sure they are tight, not corroded and not frayed.
  3. You may wish to remove the starter and have it bench tested at a parts store.
  4. Get a multi-meter and read your batteries, they may simply have run too low form sitting on a store shelf for too long.
  5. You got the correct battery type for your vehicle, right?
  • I should add that it may be worth checking that the batteries are connected in the correct polarity. I've seen this before, it's an easy mistake to make. – Steve Matthews Dec 7 '17 at 16:38
1

If your RV typically charges the house battery (a deep-cycle battery used to power the "House" parts of the motorhome) while driving, then it may be the isolator unit that is bad or wired incorrectly.

The isolator unit should be wired between your alternator and the two batteries, it allows the alternator to charge the house battery along with the starter battery, but it prevents the house systems from draining the starter battery.

I have heard of lots of strange interactions when a isolator goes bad, and a non-RV mechanic will typically hone in on the alternator as the problem component.

A temporary fix/test would be to disconnct & bypass the isolator entirely and try jumping again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.