1

The radio / clock / display says my battery is at 12.1v. Everything else electronic seems to be okay. There's no dashboard indication of a security lockdown. Some research suggests that a bad crankshaft position sensor might be causing the issue.

If you know these cars, then you know I had to disassemble a lot of stuff, unplug a lot of wires and disconnect a lot of hoses. I am fairly confident I got them all back in, but wonder if there's anything specific I should try next. I'm pretty sure that one of the wires I disconnected before was the CPS, and I'll try re-seating it again while I wait for an answer, and will update if anything changes.

I'm also having vacuum issues with the "crankcase ventilation primary" actually disconnected or broken. I haven't been able to trace it back to where it belongs so that I might replace it. I only mention it in-case it has relevance to this current issue.

EDIT

I tried the trick suggested here:04 Cadillac cts no start key stuck sidestep fix, and it cranked, but did not spark. While trying this though, the display showed "Service Theft System".

  • IS the PCM bolted to the head? I think there's a ground wire that connects to one of the bolts. I don't know if you'd have to remove it for valve cover R&R though. If the ignition cylinder lock isn't releasing the key I'd say it's a PCM power or ground problem. – Ben Nov 5 '17 at 19:09
  • The PCM, like this was mounted to a steel plate . That steel plate was attached to the intake manifold / throttle body, to a wire harness with another piece of steel, and to something deeper in the engine bay, quite possibly attached to the block. I had such a hard time getting a couple of those e-torx bolts out, I skipped putting them back in, figuring it was supported enough by the other bolts I put in it. – TecBrat Nov 5 '17 at 19:28
  • I was able to release the key by using the button under the dash. Put it back in got the same result. I tried the procedure that's supposed to re-program a key over the course of a half hour and it didn't help. – TecBrat Nov 5 '17 at 20:26
0

In my case, it turned out out that two wiring harnesses inside the fuse box weren't reconnected well, or that oil residue was causing a bad connection. I had disconnected one of them to give myself more wiggle room on one of the wire clusters that was blocking the screws to the computer mounting bracket.

Other conditions reported to have these symptoms are

  1. Failed PCM
  2. Failed Crankshaft Position Sensor
  3. Ignition Key Needs to be re-programmed

There may be other condtions as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.