4

2001 Nissan Xtrail. After driving for more than 20 minutes, the car seems to have less power. The rpm will go way up, but the car is slow. Rpm can go near the redzone, yet I’m still driving at 10-25kmph. A temporary fix is switching the car off and waiting 20 to 30 minutes. The problem will reoccur after another 20 minute drive. Can anyone help, I’ve already taken the car to two shops, but they couldn’t fix.

3
  • Welcome to Motor Vehicle Maintenance & Repair! Is the vehicle a standard shift (manual) transmission? Nov 2, 2017 at 6:02
  • If the car has a manual gearbox it could be a clutch related issue. Is the car manual or auto? Nov 2, 2017 at 10:29
  • 1
    Take it to someplace that specializes in transmissions. It seems odd that any professional mechanic can't diagnose this issue at least.
    – Tim Nevins
    Nov 2, 2017 at 14:46

2 Answers 2

1

Sounds like the clutch is slipping. Make sure there is enough freeplay in the cable/push-rod(not sure on cars as I'm a biker). If it's a pushrod system, check the seals are not leaking oil onto the clutch plates.

0

Have you hooked up a scan tool? These problems are many times caused by bad transmission speed sensors, either on the input or output shaft. When they start going bad they will be fine until they reach a certain temperature,then will start failing. Either buy a cheap scan tool or get someone to read the codes for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .