3

The Problem:
I bought the new car radio/stereo unit, installed it, but there is a problem it wont stay on when i turn of my car. And it also loses preferences (volume, radio stations, etc)

Info about the connection from the car:

  • Yellow wire - it is labeled "Battery" (on the car side), voltage is 12 when car is on, 0 when car is off. On the adapter that came with the unit, yellow wire comes with a 'thing' on it, like a bulb with the wire in the middle, don't know what it does. In the unit instructions/manual it says this wire is "Memory", whatever that means (probably always-on wire)
  • Red wire - it is labeled "ACC" on (on the car side), voltage is always 12 volts, whether car is on or off.

My Solution
So first i tried to reverse the wires, red goes to yellow place and yellow to red, didn't work, no difference at all, unit only works when car is on.

Now what i did is connect both (red and yellow) wires on the adapter to the red wire that comes out of the car, this effectively makes both yellow and red wire connected to the unit always at 12 volts. That seemed like it fixed the problem

Question
So my question is, is this a good solution, or did a do something stupid and tomorrow when i go to my car i will find it not starting because my battery is dead?
(didn't really leave it like that, i disconnected the unit, just in case :D)

  • ACC means Accessories. Are you sure the voltage is 12 V with the car off and key out of ignition? – Zaid Nov 1 '17 at 16:58
  • Yes when key is in off position its 12 v, didn't try when key is removed. – pedja Nov 1 '17 at 17:01
  • Thats weird, why would the accessory wire be red, red should be ignition, yellow should be constant power. This car is so weird – pedja Nov 1 '17 at 17:04
  • As long as it's in the Off position I don't think you'd see a difference with the key in or out of ignition. Which car is this by the way? – Zaid Nov 1 '17 at 17:04
  • Its old Fiat Bravo 1999 – pedja Nov 1 '17 at 17:05
1

Something is fishy here. It sounds like:

  • Yellow wire labeled "battery" should have constant 12 volts, whether the car is on or off. The "bulb with a wire in the middle" is probably a fuse. (Any direct connection to the battery will normally be fused). "Memory", as you correctly guess, provides a constant power to the stereo head that retains presets etc. If you get 0v when the car is off, this is probably incorrectly hooked up to the ACC (Accessory power) instead of constant 12v.

  • Red Wire labeled "ACC" should only have power when ignition is turned to ACC or car is running. If it always has 12v, then again something is not hooked up right.

Why did it not work when you switched the wires? I can't say exactly, but to directly answer the question: yes it's entirely possible for you to leave your radio on and drain the battery. However, if you really want to be able to listen to it with the car off then you would have to do something like what you have done, and splice the always on 12v to both connections on the stereo.

The only thing I might change is to make sure that always on connection has a fuse. If the line is not fused already, or there is no fuse in the panel I would suggest getting a cheap inline fuse-holder to splice into the wire. Always fuse hot connections as close as possible to the battery or other DC source.

Also if you are splicing hot connections together be aware you may be pulling more amps than was originally intended for the wire. This is exactly why you should have a fuse, otherwise the wire may heat up and melt the insulation, causing a short and/or fire.

1

Of the cars that I have personally worked on, none of them had a memory circuit that I would feel comfortable running my head unit off of; they're usually fused at 5 amps (sometimes 7.5 amps), where a head unit is usually 10 amps or more. If the manufacturer designed the circuit to handle 5 amps, you risk blowing fuses and burning wires by overloading it.

As for draining the battery, it's entirely possible, but that depends on the head unit, and how much power it draws when turned off.

If you absolutely must set yours up this way (I would not), running a wire from the battery to the head unit with a separate fuse inline is a safe bet. Your factory wiring was not designed to do what you suggest.

0

Quite straight forward. in the stereo world the conventions are as follows: Yellow wire is permanent 12V Red is Acc (ignition switched 12V) Black is ground.

Car manufacturers quite often reverse permanent and Acc locations on ISO power plug. They also use them for different functions on later vehicles, so you may find Acc wire is replaced by CAN network connection. Earth wire is always in some position.

For your 1999 Fiat Bravo, it is probably too old to have stereo CAN bus connections ( a lot of Fiats do) You will find bullet connectors in the Yellow and Red wires - undo and swop Red to Yellow and then Yellow to Red.

As for the stereo not staying on when engine is off: This may be how Fiat intended. Check the Acc with multimeter to determine when 12v Acc is present. If not ignition switched with "hold" until key removed you will needcto locate a better switched 12v from fuse box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.