1

Recently i have installed a Stereo system in my car, that works flawlessly when i play Music and Videos through an SD card or Pen drive, The problem comes when i am listening to FM radio, My Stereo system plays buzzing sounds when i pass near to High tension cables, power lines in local areas, near to transformers , when i press any buttons/switches on dashboard of my car and also when i turn on windscreen wipers. I have been noticing this from a while, and come to conclude that EMI is the real culprit!

How can i get rid with this problem.? should i add Ferrite bead to coaxial cable of FM antenna.?

Thank you

  • Make sure your stereo is well-grounded! My next statements assume that your car's chassis is considered to be ground. I don't know where you live, so I don't know if that it true for you.) Many stereos have a chassis grounding point in addition to the ground wire in the cable harness. This chassis grounding point should have it's own wire, short as possible, connected to the chassis of the car. Often the wire is simply held down by a bolt to the car. If so, ensure that there isn't any paint between the car, the bolt, and/or the grounding wire. – bitsmack Sep 13 '17 at 16:47
  • @bitsmack Are there any cars where the chassis is not the ground? I'm not aware of any such cars. – juhist Sep 13 '17 at 16:54
  • @juhist I'm in the USA. When I was young, one of the "old guys" had a positive-chassis truck from somewhere. I only know because he need a jump once and had to explain why I shouldn't do it the "normal way". I never knew if this was because of the age of the car, or where it had come from, or some other reason. Other than that, I have never heard of such a thing :) – bitsmack Sep 13 '17 at 17:01
  • @bitsmack I guess the system would be "positive ground" then, meaning the chassis is still the ground, but the ground is positive. On such a system, you can't install a radio that expects negative ground. But anyway, such cars are extraordinarily rare. – juhist Sep 13 '17 at 17:05
  • 1
    Are you sure the problem is not on AM? FM does not have this problem, unless this is an aftermarket radio without an LC choke on power. – Tony Stewart Sunnyskyguy EE75 Sep 13 '17 at 17:42
2

System ground is critical. Ensuring the system is properly grounded solves a lot of issues.

You mention this only happening when listening to FM radio. That leads me to believe the system ground is likely good, but you may have a problem with the antenna. This is easy to check.

Unplug the antenna and see if the noise continues.

  • If it stops, then you need to use an antenna noise suppressor that plugs in between the antenna and the receiver.
  • If it continues, there is likely a problem with the receiver.
  • The problem with the chassis ground, there was no connection between Stereo player to car chassis.. – Mudassir Hussain Sep 15 '17 at 10:49
0

I think the problem is in your stereo system. A long time ago, I built a stereo mixer using operational amplifiers that allowed me to have multiple sources connected to the amplifier on at the same time. Well, I didn't protect it well enough against EMI and whenever I turned on the compact fluorescent light in my room, I heard buzzing sounds.

All cars have an antenna, probably without any ferrite beads. However, most cars have a stereo system that is well-protected against EMI. Clearly, yours isn't.

First, try to check if your stereo system is grounded, as noted by bitsmack. Then, try a different stereo system if that fails to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.