2

2007 Escalade, 6.2L AWD

This morning I fired up the car, drove about 4 miles and stopped at a gas station. Filled up the tank, got back in, turned the key and... click. No slow turnover or anything. It felt like the started was engaging, but had so little power it couldn't even turn it over slowly.

While I was puzzling over this, a very nice gentleman offered to jump it for me. Hooked up the cables, waited about 30 seconds, and it fired right up (though the first revolution was a little slow, which I've come to expect when jump-starting a car. Shrug.)

When I got it back home, after shutting the car off and unloading some stuff, I decided to try it again, and it started immediately. This worked four more times before I decided to stop bothering my neighbors by starting the car over and over.

Some weird observations:

  1. When the battery was "dead," the sunroof would open, but the power windows wouldn't budge. Also, the rear hatch wouldn't open, but the glass panel would. (The glass opens independently of the lift gate, and the lift gate uses a motor to open and close, which would require more power.) Door locks worked.

  2. Attempts to start it appeared to reboot the ECM / BCM / whatever. The needles did their sweep to the right and left, the DIC displayed its startup message, etc.

  3. My son was watching a DVD. After getting the jump, it started over at the beginning of the disc, indicating to me that the unit had lost power.

  4. I saw messages for "service charging system," "service stabilitrak," and others that I unfortunately didn't make a note of. These messages have not reappeared since jump-starting.

I thought the battery might have a dead cell or something, so I pulled it and took it to O'Reilly. They connected their diagnostic tool - a box about 12" x 8" x 2" with a crappy LCD on the front and some arrow buttons - via its attached jumper-cable-like-things. After about 45 seconds, the employee said that the battery was good.

So, here's my quandary:

  • If the battery is good, why would jump-starting work? Is it possible that the battery test was incorrect? The last time I had a battery tested, it was a "drop it off and we'll call you when the test is complete" process, not a quick diagnostic like this one.

  • Doesn't make sense to be the alternator as the thing ran fine for an extended period of time after jump-starting.

  • Why on earth would the sunroof open, but not the windows or rear hatch / gate / whatever it is called?

This is my wife's car, and I don't feel comfortable letting her run around with the kids without figuring out what the problem is first. I'd also rather not spend $200 on a battery if this one is good. (It's a Delco battery, OEM spec, but I can't find a date on it so I have no idea how old it is. We've had the car for a little over a year.)

The only semi-rational idea I've had is that there is a loose ground somewhere, and that connecting it to the other vehicle to jump start it provided a good ground. This seems really far-fetched as, again, it ran fine afterward.

Doubt it is related, but I recently (about a month ago) replaced both belts along with the harmonic balancer. I see nothing amiss in the engine bay. No corrosion on the battery terminals, harness appears intact.

Help!

  • I'd think there was voltage drop between the battery terminals and posts or that one of the terminals was slightly loose. You might want to load test the battery. Maybe voltage drop the starting system if you have a multimeter with a min max feature. – Ben Aug 27 '17 at 12:45
  • @Ben I was hoping that they'd load test it at the parts store, but I don't see how that little black box could do that. As far as I can tell, this is the original battery - but I can't be certain as there's no date. Argh. – 3Dave Aug 27 '17 at 15:10
  • I suspect something is using power when the vehicle is off. Have you checked current flow with key off? – zipzit Aug 27 '17 at 16:51
  • @zipzit I have not. But it just occurred to me that my iPad was plugged up to the charger for a few days. (Left it between the seat and console and forgot about it.) I could see a situation where that mostly drained the battery but it had enough to start once, and the drive to the gas station wasn't long enough to recharge. Hmmm. – 3Dave Aug 27 '17 at 18:22
2

If you have had the car for over a year, but can't find a manufacture's date the battery may simply be old.

I had a battery that was acting up and took it to Advance Auto and it passed the test with that little plastic box. The clerk told me he was not allowed to sell me a replacement battery even for cash unless the box told him the battery was bad. I was not happy but held my tongue and insisted the battery had failed to start multiple times and asked him to check again. On the second test it failed. I figured there was a cell with damaged plates or sludge on the bottom that was shorting out some times.

You could recheck all the body grounds. If your Escalade is high mileage you might consider getting rid of it before something worse happens. This forum is an interesting read: http://www.cadillacforums.com/forums/cadillac-forum/t-261727.html

  • I found the date - Delco code "P123R", or December 2013. The 42 month warranty just expired, of course. I'm surprised they wouldn't sell you a battery - weird California law? – 3Dave Aug 27 '17 at 20:06
  • @DavidLively - Sounds like more of a store centric thing. If you go in there without a battery, would their tune be different? I'd suspect. – Pᴀᴜʟsᴛᴇʀ2 Aug 27 '17 at 20:41
  • A Dec 2013 battery has lasted longer than most would in a hot climate. Here in south Florida if I get 3 years out of a new battery I consider it a decent battery. Advance Auto wouldn't sell the battery without the fail ticket to protect themselves from accusations of fraud for selling something you didn't really need. – David Nix Aug 30 '17 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.