4

This is the final question to my DIY ford ranger repair series. You can see the first two here:

1) Is hot desert weather the source of my recurring car problem
2) Procedure for throttle body and idle air control replacement ford ranger

I have since replaced the throttle body, throttle body gasket, idle air control valve, and idle air control valve gasket. I followed the procedure as outlined by the kind folks in the second of the listed posts... Well, I followed all except the final step of reconnecting my battery.

The problem is that when I connect my battery back up (connecting positive first, then ground), the moment I touch the ground cable to the negative terminal my car starts laying on the horn!. Not just a honk, but a solid laying on the horn.

What I've done so far to troubleshoot:

  • Cleaned all acid buildup off battery cables and terminals
  • Checked that the connections removed during the throttle body replacement were both snapped in, and not backwards, specifically the:
    • throttle position sensor electrical connector
    • idle air control valve electrical connector
  • Checked the three non-electrical cables connected to the throttle body
    • accelerator cable
    • speed control cable
    • return spring
  • Checked that nothing was in the "on position" inside car (lights, wipers, ac/heat, etc)
  • Checked the battery was not in backwards
  • Replaced with new battery (was old anyways)
  • I identified the horn fuse in the circuit box and I switched that circuit with one of its neighbors. But it still honks.
  • The last thing I have done is I took the horn fuse out and connected the battery. No honking horn. BUT the door ajar chimed erratically, the passive anti theft system light (underneath my steering wheel) was blinking, along with a small clicking sound (like maybe the turn signal indicator).

I can't figure out what I did wrong! car specs: 2004 ford ranger edge, v6, 3L, gas, vin u, 130000 miles

  • 1
    Glad it is resolved, but please do not add [SOLVED] to the title. This is not a forum. You did answer your own question with what fixed it. As soon as allowed, you should mark it as accepted. That will let others know there is a resolution. Thanks. – CharlieRB Jul 26 '17 at 13:33
3

Well I figured it out. The issue was unrelated to the throttle body or any repairs I did.

The problem was because I completely removed my battery. Upon re-installing the battery, the cars passive anti theft system (PATS) was engaging. Strange, because I was never aware I had an alarm system.

Solution:
1) remove car horn fuse
2) close door and lock
3) connect battery
4) open locked door with key
5) insert key in ignition.
Bingo, problem solved.

  • Wow, what a stupid design decision by Ford. Glad you figured it out! – Spivonious Jul 26 '17 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.