1

I recently changed my own oil and oil filter, successfully. I have a 2015 Toyota Highlander. I need to reset that annoying little maintenance light. This is the light that comes on after a preset distance has been recorded on "Trip A" or "Trip B".

Now - I've read the users manual and I've reviewed videos online of people resetting this light. My problem is, I cannot correlate what they (the people and the manual) describe and what I see on my dash.

Now, the display is located between RPM meter and the speed meter. On the speed meter there is a button that sticks out with "ODO TRIP" right next to it. On the actual display itself there is a line near the bottom that says "ODO XXXX miles".

Everywhere I have read online (and in the manual) is "oh, just reset Trip A or reset Trip B". Problem is, I do not see either on my display. From memory I know I've seen Trip A and Trip B on the display in the past but for whatever reason they no longer appear.

I really don't want to screw anything up here. I just want to reset my maintenance required light.

Could anyone please comment? I appreciate your time in this matter.

  • On my Tundra, I push odo trip until I reach the Trip A screen. Turn off vehicle, while pressing and holding odo trip, turn ignition to on (don't start). The screen will flash dashed lines for 5 seconds or so. When it stops, the light has been reset. The procedure should be located in your owners manual. This isn't something only a dealer can do. – cory Jun 27 '17 at 12:22
  • Hey - Thanks for the tip. I did what you said and I saw the "------" and then the "00000" and then the maintenance light went off. So that is good and I appreciate the input. Now my problem is that neither Trip A or B seemed to actually have been zeroed. My manual says to go to the "settings" screen on the multi-informational display and to reset the maintenance information there. Unfortunately the only settings I see under "settings" are language, units, and eco meter. Any thoughts? How do i get Trip A or B to back to zero? – Nukesub Jul 6 '17 at 0:09
  • With the car on, toggle to trip A using the odo trip button. Then just hold it for a second or two and it will reset it. Do the same for trip B if you like. – cory Jul 6 '17 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.