Turns out the computer was shot, entirely non-functional. Swapped one out and the car started right up. For future readers: The computer is a likely cause if the vehicle has power, yet multiple unrelated parts that connect to the computer are non-functional. For me this included code puller, starter, fuel pump / guage, power steering.

Thanks to: 1. Ben for the troubleshooting advice. 2. AllComputerResources.com for the replacement computer. Theses guys are awesome. They sent me a pre-programmed computer for only $130. Dealer wanted $860 for the part and labor to program it. 3. StackExchange for hosting such a great resource.

Original Post:

I've tried everything on this car, except what's wrong. I just need you guys to tell me what that one thing is. Car details 2009 Chevy Malibu LT, 2.4L I4

Problem Description: When I turn the car over to start, I get nothing. All the guages on the dash and all go off, but there's no crank, no sound, nothing. When I turn back from start to on, all the guages, radio, etc power back on. All the electronics turn on and get good power in the on position lights, radio, windows, etc. It's when I turn to start, I get nothing.

This video is my exact car with (seemingly) exact problem and NO solution... Ugh. https://youtu.be/0pcNTu5mycA

Here's what I've tested:


Took it to autozone for testing. They said it's good. I also tested with multimeter. It looks good. I've tried jumping it anyways. Doesn't help.

Terminal Connectors

Both good now. One was pretty corroded, so I replaced it. Tested connections with multimeter, both good. Cleaned the terminals. I also think the connections are good because I read power at the starter.


Tested at Autozone. They say it's good. Also bridged the constant power node to the negative, and could hear the (starter) motor turn (wirings good!). Car did not start (I don't think it should?). There's a second power into the solenoid from the ignition. I can't bridge that because it's got this annoying plactic connector plug. I've tried giving it several real solid bangs with a 2x4 before and while turning the key.

When I turn the key there is NO power going from the solenoid to the starter (braided cable). Don't get too hung up here yet.

Relays: Starter / Ignition

Tried switching around relays to see if there's a bad one. Unless they're all bad, not a problem here.

Also, turning the key to start does not cause any relay to click. Setting the security system off causes the headlights relay to click repeatedly. (Probably irrelevant here).


Removed and visually inspected every fuse, in all 3 fuse boxes. I didn't test them. I just looked to see if the plastic was burnt and the little wire inside was broken. I've seen 2 broken fuses before, and they were both obviously bad.

Ignition Switch / Passlock Sensor

Changed it yesterday.

I'm also getting constant power into the red (slot 2), and yellow (slot 6). I get constant power into one cable on the passlock (forgot which color).

I tried moving the steering column up and down forcefully a few times. No help.

Ignition Lock Cylinder

Believe it's good. I get the accessories on. It also still gives resistence in the start position, and turns itself back to on. It also physically locks the (something) cable into the ignition switch

Neutral Safety Switch

I know it exists. I haven't looked at it. I have tried shifting through Park to Neutral to Park to Neutral, etc, several times.


My only key is a replacement key. I got it cut at the dealer and programmed myself. I could re-program, BUT the security light isn't coming on. If the car didn't recognize the key, the security light should come on. That's at least how it worked when I first got the key. There is a passlock sensor above the ignition switch. I'm not suspicious (no light), but it does make the wiring more complicated.


THIS might be my next lead. If you pay close attention in that video, the fuel guage doesn't lift off empty, even in the on position. I think is on it should show the fuel level. I put my last 1/4 gallon from a can into the car, and still didn't see it move. I'll try putting 2 gallons in and see if that moves the guage, and starts. If NOT, I'd guess it could be an electrical issue with the fuel system. Whenever, I've not had enough fuel before, I at least got a sound that the engine was trying though.

Engine Light Codes

Can't read them. I have a code reader, that I've used on this car before (2 months ago), and now it gives an error, and won't read the codes. I don't think this is related, but maybe the computers dead: losing the codes and ability to start? Pure conjecture here. I know nothing about car computer systems.

Recent History

This issue seems to have started suddenly.

It had (different) intermittant start issues leading up to this due to a bad terminal connector. The thing was so corroded, it cracked and wouldn't tighten. When turning the key you'd see a visible spark on the negative terminal, and all power would go (like a dead battery). Adjusting the negative cable would reestablish power. After a couple tries, the car would start. This is why I changed the battery terminal connector to begin with. Was surprised to see these symptoms immediately after.

Otherwise, no starting or running issues before this.

What do I do? If you actually took the time to read all this, THANK YOU. If you have any adive to add, THANK YOU again.


Checked the starter circuit as described by Ben's answer. Good power and ground to the correct relays. All fuses are good.

Checked wiring to ecm. Ground on X3 73 is good. Confirmed B+ power to terminal 20 red-white on X1. I have no power to terminal 19 pink on X1. I checked backprobing, and plugging into the front of the connector (wanted to double check). I re-checked in the fuse box, and have power to both ecm fuses.

Jumped power power to terminal 19 (pink). Still no start. BUT! Normally, when I turn the key to start, all power in the cab / dash shuts off. This is normal. NOW, with power to the ecm, all of those components stay on. Which I don't think should happen but it does.

Additional NEew(ly recognized) Symptoms I should have paid attention to this earlier, but on the dash where the service blanks codes show up, I'm getting a bunch... 1) Power steering, 2) Service ESC, 3) Service Traction, 4) ESC off, 5) Low Fuel. I'm assuming this should make it clear what's wrong. I'd guess all these feed through the ECM, but I personally don't know.

Thanks again.

UPDATE 4/3 Towed to dealer (read admitted defeat)... They say the ECM is shot. I'll update again after it's replaced.

ANSWER Sorry, I forgot to give you guys the good news. It's been close to a year now, but the computer was bad. I swapped it out and it started right up.

  • Putting a +1 on this. Great effort in the writeup and lots of information to go on here. Commented Feb 24, 2017 at 15:31
  • agree, use one jump lead direct from the battery earth (not red) - side direct to the metal of the engine and try again. Check brake light switch works, as this could have an affect on the automatic gearbox "not in park" stuff safty disable, ignition on press brake jiggle shift lever in neutral and back to park, make sure brake ligths work. try again. It does seem you have cable problem, or a direct to earth fault, you got the battery on the right way round ????? last thing is to pull every big 30 -40 amp and check each one,, at a time. good luck
    – user26112
    Commented Feb 24, 2017 at 15:55
  • Great explanation. When did this begin? Was there an event that led up to this? Rough running, difficult to start, dead battery, service / check engine light, etc? Or was this a sudden issue?
    – CharlieRB
    Commented Feb 24, 2017 at 16:04
  • @CharlieRB Edditing to put history in the question. Commented Feb 24, 2017 at 16:07
  • 1
    I had the same problem with mine bought a new CPU and started right up Commented Mar 6, 2019 at 15:26

5 Answers 5


On GMs now adays the Engine Control Module controls the starter relay. It will look for a park/neutral signal from the range switch and a crank signal from the ignition switch/Body Control Module.

enter image description here

A break down of the starter relay terminals. If you pull the relay you'll see it's labeled on the bottom and has a diagram on the side.

85 - ECM sends power to this terminal to energize the coil.
86 - Grounded to the frame.
30 - Fused, always hot (B+ - Battery Positive).
87 - Goes to the starter solenoid.

Pull the relay, check terminals 30 and 86 for power and ground. Be careful when probing the relay terminals if you can't touch the relay terminal with your multimeter probe don't try to force it in. Use a small pin or attach a male terminal end that properly fits the terminal to a piece of wire.

Start with terminal 30, if you don't have power (12+v) on terminal 30 or if you have less than battery voltage check the starter fuse in the underhood fuse block. Ground your multimeter to the B- (Battery Negative) and probing the exposed terminals. Is there a difference in voltage between either post? If so replace the fuse. Visual inspections don't always reveal issues with fuses. If there is B+ voltage on terminal 30 move to the next terminal.

What about terminal 86? Is it grounded? Check the ground point G109, is it clean and tight?

enter image description here

How about terminal 87? When you probe the terminal it should be grounded since the starter grounds to the engine block. If it's not check the engine block to frame or battery connections. What happens when you jump power to terminal 87? Since you had the starter tested it should spin.

So onto terminal 85, where I suspect the problem is. You stated that there was no communication with the ECM (It's possible it's the scan tool, but unlikely in this case.) and the check engine light didn't come on KOEO.

So, where to start? Check the ECM and ECM IGN fuses in the underhood fuse block the same way you checked the starter fuse. Is there a difference in voltage between the two fuse posts? If yes, replace the fuse. If both fuses are OK, you need to gain access to the ECM. On the 2.4 the ECM is located in the left front of the engine bay.

Off the top of my head I don't remember the type of connector that's used. In general there should be a lever with a tab that needs to be pressed down. This could also be a 7mm bolt that needs to be loosened and the connector will pull out. Or it could be a sliding lock that needs to be pulled.

Once the connector is released from the ECM, there is a plastic cover that protects the back of the connector. There are usually four tabs that hold it in place, this cover needs to be removed. On the front (sometimes on the back) of the connector you should see labels Identifying the first and last terminals of a particular row.

A note on checking ECM connector terminals: Best practice is to slide a backprobing pin along the wire, being careful not to damage the weatherpack seal.

You're looking for connector X1 terminals 19 and 20 (pink and red/white respectively) these should both have B+ voltage. And on connector X3 terminal 73 (black) a ground. Terminals 19 and 20 are the ECM and ECM IGN fuses. If you see less than B+ voltage there is a problem with the wiring from the underhood fuse box to the ECM. Terminal 73 grounds to the engine on the 2.4, G107.

enter image description here

So if everything on the start circuit looks OK and the ECM is getting power and ground. It could be that the ECM is bad and needs to be replaced. Another possibility is that there is a problem with the GMLAN data bus.e.g. one module is bad and shutting down the network.

  • Ben, I haven't forgotten about you. I've checked all the first part on the start circuit. I still have to get to the ECM checks. I'll let you know how it goes. Commented Mar 1, 2017 at 13:15
  • Ben! Checked wiring to ecm. Ground on X3 73 is good. Confirm B+ power to terminal 20 red-white on X1. I have no power to terminal 19 pink on X1. I checked backprobing, and plugging into the front of the connector (wanted to double check). I re-checked in the fuse box, and have power to both ecm fuses. I'm guessing, I've got to pull all that black casing of the wiring and trace that pink wire from the X1 connector back to the fuse box? Any tips on this? Also, is there anything I can do to double check that it;s that pink wire, before I pull all the wiring apart? Commented Mar 5, 2017 at 19:49
  • @DylanCross try jumping power to terminal 19 while it's plugged in and see if the ECM powers up. To the fuse box, when you unbolt it there should just be a plastic cover on the backside held by tabs. Which connector the pink wire goes to depends on which engine you have. It's labeled in the wiring diagram I think.
    – Ben
    Commented Mar 5, 2017 at 21:35
  • @Ben, I tried sending power to terminal 19 on the ECM. No luck. Although, it did prevent the dash power from turning off when turning the key to start. I added an update to the bottom of the main post. I also noticed a bunch of service codes in the dash. More details above as well. Thanks. Commented Mar 9, 2017 at 2:16

Looking at the video, it appears to be an electrical problem. It looks like the main power leads are losing their continuity when you turn the key to activate the starter. This issue could be ANYWHERE along the main lines of your power cables. Mainly four points to look at: (+) connection at battery and at starter; (-) connection at the battery and grounding point at the body. A way you can test this is to use a pair of jumper cables and attach the (+) lead to the main post on the starter solenoid and the (-) lead to anywhere on the starter case you can attach it. Use a donor car as the power source and attach the (+) lead to the battery and the (-) to a good ground source away from the battery.

(NOTE: This is backwards of how you'd normally attach jumper cables, but since you are putting the ends on the starter and the starter is in a remote location, it makes sense to put these first to avoid contacting anything which will cause a spark.)

With the donor car attached to the jumper leads, attempt to start your car. If it will turn over, you know it's in the power leads somewhere and most likely a connection issue. If it still won't start, the problem is most likely in your ignition switch.

  • Was thinking the same thing, but found this video of the exact same car. You will notice the dash goes completely dark during start.
    – CharlieRB
    Commented Feb 24, 2017 at 15:45
  • All the electronics are supposed to go off when you start it. This cars weird. @CharlieRB I watched that same video, to see what the startup should look like. Commented Feb 24, 2017 at 16:15
  • Question on your starter test. My starter has 3 connections. 2 big bolts holding wires on (+) and (-), and on little wire with a plug (from ignition?) Do you want me to connect the (+) cable to the big positive post or the little plug wire? Also, I tested the voltage with a voltmeter between the two big posts at 12v without turning the key. So I get constant power to the (+) post. I haven't checked to see if this drops when I turn the key. Commented Feb 24, 2017 at 16:21

Thinking more, you turn the key, massive voltage drop as the starter tries,

1) bad earth to the engine: connect the battery's black wire to a good metal part of the engine, as it is trying to earth through your wiring system.

2)try if you can to turn the engine backward or forwards by hand with a spanner on the bottom pulley, the starter motor could be stuck in forward engage or jammed, this could release it.

even more good luck.


I had the same issue on my F150 down to the initial hard starting. In my case it was the ground wire to the frame being so corroded current wouldn't pass beyond a trickle. I cleaned up the contacts and those for the starter (since that's where I thought the problem originally was).


I was ready to give up on my 2009 Chevy Malibu as I tried all and everything that was said here.

I replaced the fuse box and it looks like that is where the problem was. I ordered it online used for $45 plus shipping and replaced it myself it took me about 1 hour (the blocks underneath were extremely hard to pull out).

Anyways hope it helps some.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .