I'm trying to program my 2007 Prius to open my garage door. I succeeded doing this for my 2006 Highlander with no problems. However, for the prius, I cannot get the car to work as described in the manual and suspect something is broken or some fuse is blown. The mirror is where the 3 programable controls are located.

I tried with the adaptive mirror darkening turned both on and off. When it is on, the button between the first and second homelink buttons glows solid green, when the mirror is off this led is off.

When holding the remote next to the mirror with battery side pointing away from the mirror and holding the remote within 1 to 3 inches of the mirror, I simultaneously hold the button I want to program and the garage door opener down for over 20 seconds, but the led never changes. Note my garage has a rotating code as I discovered doing the 2006, but I cannot even get to the second step.

I also tried to reset the homelink and erase everything by holding down programable buttons one and three simultaneously for 20 seconds but not more than 30 per the manual, but again, no LED response as described in the manual.

What is going wrong and how can I get this resolved so that I can successfully program my remote into the car?

3 Answers 3


If you are following the instructions and you have checked all the fuses I would take it to the dealer and let them diagnose it. It sounds like you have a problem with the system in the car that will likely require replacement of the homelink module.

  • I'm unable to determine which fuse to check, none of the labels seems to apply. What label should I look for? Is it the fuses in the cabin or under the hood?
    – WilliamKF
    Commented Aug 20, 2012 at 20:46
  • @WilliamKF check the owners manual, or just check all the fuses. If the LED is lighting up however it's most likely not the fuse. I would still check them anyway as there may be a dependance on something else for the homelink to work correctly Commented Aug 20, 2012 at 21:51

I took the car to the dealer and they determined that when I had my windshield replaced the cutter tool that they use to free the old windshield was used they cut too deeply and cut some of the wires. They replaced the wiring and homelink now works plus it also fixed issue with the dome light not coming on when the door was opened.


I have the same problem, my 2006 Homelink worked fine, car was totaled three weeks ago, 2007 Homelink will NOT work. I have followed all the steps repeatedly, even erased it first, all the red and green solid, slowly blinking, and rapid blinking lights work, but nothing. I only mention this because I took it to the dealer today, as suggested here, and they can not get it to work either. All they said was, "The lights are working, so the Homelink works." Period. So don't expect your dealer to be any help at all...

Edit: I read through some other threads, and found this link to the Homelink website: http://www.homelink.com/program/watchvideo The directions are different than the ones in my Prius owner's manual, and worked like a charm. Since we have a Genie with rolling code, I had to get up on a ladder to push the button INSIDE (not on the back of) the overhead opener, and the button was not orange or labelled Learn or anything else, but once I pushed it and got back inside the Prius quickly and pushed the Homelink button until it blinked, three times, and it works now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .