1

I was driving back home from work today when my windscreen started getting misty so I switched the electric demister on. In the past it has caused the car to sound slightly more laboured than normal but today I'm getting vibrations and it's noticeably louder! The noise comes from behind the front left wheel and slightly up (about level with the uppermost curve of the wheel arch) inside the engine bay. I hear the metallic vibration noise more often than not but more so when I turn the demister on. I know the fuel pump is now placed in the engine bay of the mk7.5 fiesta ecoboost but I've checked that and whilst it's noisier than most cars I've driven, the noise is not coming from that. Any ideas?

  • Does the defroster engage a clutch for the A/C compressor? Alternatively, does turning A/C on result in the same symptoms? – silentsod Feb 6 '17 at 18:52
  • It definitely sounds like it does engage something but not the A/C compressor itself if that makes sense? I turned the A/C itself on and over the whirring noise of the compressor I could hear and confirm that it does show exactly the same symptoms. – Josh G Feb 6 '17 at 19:19
  • My guess would be that the clutch/pulley bearing is or has died and it no longer rotates freely and smoothly. – silentsod Feb 6 '17 at 21:08
  • Thanks for the help, I'll run it in to the dealer and have them look at that. – Josh G Feb 7 '17 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.