1

I have:

BMW 330D, 2001 year, saloon, 135kw

Recently I have change the turbo charger of my car. There was a problem related with this post.

Then I went to the garage and they ran the diagnostics. Diagnostics showed that the EGR VALVE is broken. I have change the EGR valve as well, but the problem still remains. There is no power until the tachometer reaches 2000 and I need to release the pedal a little bit and then press it again, then the turbo is on and power comes back.

I am thinking maybe there are some errors in the car's computer that needs to be cleaned? How do you think? If I clean those errors, set everything related to them to zero, maybe it should solve the problem? I heard that if there are some errors left and they might cause this problem, because the parts (turbo charger and EGR valve) is new and car's computer is not aware of them until I clean the old errors?

Any advice would be very appreciated.

1

If you haven't found the answer in the turbo or egr yet, just thinking out loud, I can think of two possibilities

  1. Boost sensor - the comport uses this to determine waste gate control, and also uses this in many cases to determine egr flow.... If it is reading high, the computer may dump boost early, and assume the egr is not flowing enough.

  2. Not familiar with this engine, but if a knock sensor had to be removed for turbo replacement, the mounting bolt being loose by merely half a turn can cause all kinds of weird running issues, especially with turbos

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.