3

I have a 1996 hyundai accent and after driving to a few places with no problem. But while coming up to a traffic light I stepped on my brake to slow down and my stereo went off, I released the brake and the stereo came back on. Each time I braked it turns off, let off the brake and comes back on. I pulled into a parking lot and put it in park. I let it run for several minutes,then decided to turn it off. It didn't start I needed a jump. Once I got a jump I got it home and while it was running I took a video of what it was doing. It started cutting out then died. It didn't start again. Please help me I need my car desperately. Thank you.

  • Make sure your speakers are fitted correctly. Not jumping around or shaking. – devst3r Jan 27 '17 at 10:33
  • One thing to clarify: does the stereo cut out if you lightly press the brake pedal or only when you are stopping relatively hard? This could help tell you whether something needs to shift around to cause the fault or it is purely electrical. – enderw88 Jan 28 '17 at 15:36
3

I suspect you have a bad earth / earthing problem. Get an assistant to tell you what the tail lights are doing when you brake with the stereo on. I think voltage is probably leaking back somewhere. First step is to check all of your earthing points.

I have a similar issue on my Mk1 Golf at the moment; when it switch the headlights on, the temperature warning flashes. When I switch them off, it stops again.

2

It sounds like this could be a problem with the alternator.

The alternator is what provides the electric to your car whilst it is running. If it is not functioning correctly then it will not have the power to run everything on the car, possibly why you say the stereo dies when you brake. The additional draw of power to the brake lights could bring the voltage down.

The alternator whilst providing power to your car whilst running it also charges the battery on your car. If the alternator does not provide enough power to run your car it will not be charging up the battery. This is why the car will not have started.

You can see if the alternator is working by getting the car running and holding a volt meter (a multi-meter will do this) across the battery terminals and the voltage should be over 13v.

  • 1
    I would mention the way to diagnose whether this is an alternator problem: turn on all electric accessories other than brake lights (rear window heater, seat heaters if equipped, fog lights, backup light by choosing the reverse gear). If this additional load doesn't cause the stereo to turn off, but pressing the brake pedal does, the problem is probably not the alternator, as the alternator doesn't care what type of load it has, only how much load there is. Also, the battery may be dying too: lead-acid batteries don't like to be undercharged for long amounts of time. – juhist Jan 27 '17 at 18:37
1

You have two issues that may or may not be related.

  1. Car doesn't start. This could be due to an empty or faulty battery, or a wiring problem. Do you have a multimeter? Check the battery voltage. If the battery is empty, this may be caused by a broken alternator, or maybe the battery is just end-of-life because it can't hold enough of a charge anymore.

    Check the wiring, esp. the battery terminals and the wiring from the battery to the starter motor. You could have a loose connection that cuts out intermittently.

  2. Radio switches off during braking. This could be a wiring fault (loose connector that disconnects during braking, a loose loudspeaker that moves around under braking so that one of the loudspeaker wires touches the chassis, etc.) Is the radio the only system that switches off when you brake?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.