I've got a '95 Mercury Mystique that I have been trying to fix the A/C or for awhile (as budget allows). I just had an overhaul from the shop...

  • Had a new compressor installed - the old one had electrical problems (this was the core problem I believe)
  • Had a new accumulator installed - old one was in poor shape
  • Got a freon recharge - mechanics tested for leaks one day after recharge and found none

It was working really well for a couple days, however now the cool air comes and goes. My first guess is that the compressor is not kicking on, but I don't know the best way to test it. Ideas? Thank you!

  • 1
    On my VW, the compressor is engaged by a sort of clutch mechanism. You can see visually when it engages and disengages. By watching the compressor and turning the AC on/off you might be able to see visually whether the compressor is engaging reliably.
    – nibot
    Commented Aug 7, 2012 at 12:42
  • My mechanic told me that exactly! Said he had a hell of a time getting it disconnected, something about the hoses getting fused into it?
    – jocull
    Commented Aug 8, 2012 at 6:35

2 Answers 2


You can visually verify if the compressor is running by watching the clutch engage and disengage with the climate controls set to A/C. If it's engaging and immediately dis-engaging on a warm day, the system is probably low on freon. If it's not coming on at all, you'll want to check the relay and the wiring. The relay is in the box on the driver's fender side under the hood. You can swap in a known good one or have a finger on it while somebody toggles the controls in the cabin, you should be able to feel it engage. A multimeter on the terminals works, too, but you'll need to know which ones to check. A service manual would be handy for looking that up. If the compressor is getting power but it's not coming on, the system could be totally empty or the pressure switch might be faulty.

Check the condenser up front with the radiator (trace the lines from the compressor). Is it dirty?

If the compressor is running, but you're not getting cold air, you might have a clogged expansion valve / orifice tube. It's up under the power steering resevoir.

If it's hot when stopped and idling or moving at low speeds, but fine when at highway speeds, you might have a fan problem (or a really dirty condenser or a lot of bent fins on the condenser, or some combination of both). When you turn the system on, one fan should engage immediately and stay on. The other will come on when the powertrain controller decides things are getting too toasty under the hood. You can verify operation of both fans by pulling the coolant temp sensor connector. It's on the driver side of the engine, at the front, in a plastic housing. With it disconnected, the powertrain controller should command both fans on to maximum since it doesn't know what the coolant temp is. Watch out, this could throw a code and illuminate your check engine light.

If the compressor is staying on for a while, check the pressure in the system at the service ports (stay away from the high pressure port unless you really know what you're doing) or have somebody else do it if you don't have a decent set of guages. If there is too much or too little freon, the system won't cool.

I've been in this type of vehicle in the summer. You just don't seem to get really cold air out of the vents when it's really hot outside at low speeds. Though I've never been in one that was factory fresh, so I can't swear there isn't something wrong somewhere, but I've checked everything I mentioned. Outside of stop and go traffic, 40 degrees at the vents is doable on Max A/C once the cabin has had time to cool down.

Oh, and a pressure test after 1 day does not prove the system is tight. Just that if there are any leaks, they're fairly small. If it's still at spec pressure after a week or more of running in hot weather, it's tight.

  • Thanks for the tips! I just went out and checked on it... magically everything is pretending to work now. The compressor is running, cool air is coming out. Planning to drive for at least a couple hours tomorrow so I will see what happens. Right now I am leaning towards low freon - I'll have to see if it shuts off after running for awhile, it's likely to be hot out tomorrow.
    – jocull
    Commented Aug 9, 2012 at 0:55
  • I took it on a drive today and the air worked for maybe 5-10 minutes, but then reverted to outside air temperatures. My best guess is that the compressor seized up, but I did not get out to check it out. (Late for work!)
    – jocull
    Commented Aug 9, 2012 at 20:04
  • Thanks. I checked the compressor later today and it didn't seem to be running. Gonna get under the car with a multimeter soon and see if I can figure out if there's something up with the relay.
    – jocull
    Commented Aug 10, 2012 at 4:51
  • Thanks, Mark. I've got the Chilton service book here too.
    – jocull
    Commented Aug 12, 2012 at 21:44
  • I was able to locate the problem - it's simply a loose electrical connector on the new compressor. You can jiggle the cluster of wires running into it around and it will kick on and off. I'll be taking it back to the shop to have fix up the connector. It's a pain to get to because it's under the engine. Thanks for all your help, everyone!
    – jocull
    Commented Aug 16, 2012 at 0:11

If the compressor clutch is activated via relay, it may need replacement. As they get older it's fairly common for relays to get sticky and intermittently work. I've got that going on with the power steering relay on my MR2. Sometimes it just sticks and the power steering doesn't work until it frees up again (there's a couple methods to free it up again). Not quite annoying enough for me to actually spend the money to replace the relay yet... :-)

  • Thanks! I will look at that too. I took it on a drive today and the air worked for maybe 5-10 minutes, but then reverted to outside air temperatures. My best guess is that the compressor seized up, but I did not get out to check it out. (Late for work!)
    – jocull
    Commented Aug 9, 2012 at 20:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .