8

The bike is a Hero Honda Splendor Plus, and I've been seeing some fluid on the engine area for a month. Earlier I used to ignore it and wipe it off, but it returns. The bike's mileage has also reduced, which makes me concerned. I assume it would be some kind of oil leakage, because petrol would've evaporated immediately. Didn't see any obvious signs of tube cuts though. Pictures below.

Left side of the vehicle: enter image description here

Right side of the vehicle (The engine oil dipstick is tightly lodged, so am sure it couldn't be the engine oil that's splashing out):
enter image description here

Right side view of tubes above:
enter image description here

I know I should show it to a mechanic, but before going there, I wanted to know what could be the probable causes and if it is something I could fix myself. Mechanics here have a habit of exaggerating the cause and overselling.

  • GREAT question, btw! Awesome detail, with excellent pics. YOU were the reason this question got answered, my friend! – Lynn Crumbling Nov 28 '16 at 12:24
  • That's very generous of you to say that. Thank you :-) – Nav Nov 28 '16 at 12:28
7

While this is an educated guess, I'd put money on the fact this is oil coming from the oil filler cap. It appears the cap isn't sealing completely, or possibly the cap isn't screwed on tight enough. If tightening it a little more doesn't work, you'll need to replace the seal on this to get it to stop. The seal itself may be an o-ring type, or it could be built in. If built in, you'll need to get a new cap.

Before replacing the cap, completely clean the area of the dirt cake which is starting to build. A clean engine is a happy engine. This will also help you ensure any effort you put into getting the slight oil leak to stop is successful. When you do clean the area, just use soap and water and a scrub brush. ENSURE the engine is completely cold when you do this. Putting water onto a hot engine can cause warpage and damage the engine.

  • Thank you. That might be it. It's the area which has the most amount of liquid spilt on. Although it does surprise me about how it has flowed to so many other parts too. I guess this would also need a re-fill of engine oil. The engine has been going off when I start it the first time and try to accelerate the first time. – Nav Nov 26 '16 at 14:16
  • @Nav - The amount of oil shown is not a lot ... it doesn't take much to create what appears to be a lot. You can check your oil, but I'll bet loss will be minimal. OIl tends to spread very easily as well. As the dust makes a goop, the oil travels through it to create what you're seeing. I'm not for sure this is your only leak, but it appears to be the major contributor. – Pᴀᴜʟsᴛᴇʀ2 Nov 26 '16 at 15:09
  • 1
    Part of what makes oil so good at its job is the ability to spread out and move through small spaces… – dlu Nov 26 '16 at 20:23
  • 1
    Bingo! Y'all were right. The o ring seal was not positioned properly and there was some grime on the rim of the place where the oil filler cap sits, so although it was tightened, there was a gap through which the oil escaped. Cleaned it thoroughly and now there's no leak. Thanks a lot guys. Saved me a trip to the mechanic, and it's really admirable how you were able to troubleshoot the problem just by looking at some pics! – Nav Nov 27 '16 at 15:23
  • @Nav - No worries, and thanks for giving us confirmation on the issue. The pics were a GREAT help! – Pᴀᴜʟsᴛᴇʀ2 Nov 27 '16 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.