3

I have Cadillac CTS 2007, yesterday when I started a car I got a peculiar issue where all electronics (radio, sat-nav,..) went off, car would still drive though. So I kept on driving and when I got to work I could shut down the engine and ignition but it wouldn't give me the key (it would go two positions and not 3 necessary to take the key out).

I then noticed that lights next to automatic gearbox were off. I then tried to start a car again and it started ok (sat-nav and radio went on), but when I would shut it down it would still not give me my key!

I then called 'the AA' he checked the fuses and fault codes but couldn't do anything on the spot.

The AA report:

How we assisted Patrol found the following fault code/s:
System : Engine control - 47N / Motronic ME 9.6
U1300 - Unknown fault. Error Message : .P1629 - Fuel shut off by immobilizer. Error Message : Incorrect signal.

carried out battery reset ,loss of gear selector lighting ,suspect ecu cant see veh in park so wont release key

His (and my) theory is that gearbox does not 'know' that it is in 'park' and this is why It would not let key go.

How plausible is my theory, what am I looking at?

  • Why the downvote? – Matas Vaitkevicius Nov 17 '16 at 9:23
  • This may sound obvious but make sure your battery is fully charged. – Steve Matthews Nov 17 '16 at 11:54
1

You're going to need to either bring the car into a shop or you need a enhanced obd2 scantool to confirm the u1300 code and see which module isn't responding. The ignition cylinder lock is controlled by the PCM with inputs from the range switch and the console shift module. You may be correct in thinking that the vehicle doesn't think it's in park. You could try to move the range switch by hand or check the switch pins to see if it's passing ground or ign to the PCM.

I've had to replace PCMs on these cars before due to it not releasing the key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.