5

I bought an old Honda Fireblade CBR900 RRX a few years back and it's blown the rectifier/regulator a few times. After a recent investigation I discovered that where it was housed was way too hot (the bike has been modified) and it wasn't getting any air circulation so the connector plug to the main wire harness overheated and melted.

A mechanic fitted a new regulator/rectifier and the bike seemed fine. The system is charging fine but now there is an issue where there is a slight lag or delay in midrange power. I notice this more in 3-4 gear at about half to full throttle. I lifted the tank off and didn't see anything disturbed - all the fuel lines looked ok.

Any advice or feedback related to this issue is greatly appreciated.

  • What year is your 900? – DucatiKiller Sep 23 '16 at 17:42
  • This sounds like an issue with ignition advance. – Eric Urban Sep 25 '16 at 18:41
  • Yep the year is 1999 - at the moment the bike is with someone , they are going through it , but im thinking the problem lies with the generator - seeing as it is blowing rec/regs . When the bike was modified it blew a rec/reg , the guy fitted another , my suspicion is he did some welding on the bike without disconnecting the battery and when the rec/reg went put another on without checking the stator ( moral of the story DIY ) still early days but thats my guess – mat Sep 27 '16 at 8:01
  • Was the post helpful in any way? Did you resolve the issue? – DucatiKiller Oct 5 '16 at 20:14
2

Background

Your regulator/rectifier does two things.

  • Converts AC current to DC current

  • Regulates voltage into your battery

Common Rectifier Issues Across Manufacturers

The plug coming off the rectifier into the harness is a common weak point across motorcycle manufacturers. I have seen issues with Ducati, Aprilia, Suzuki, Honda, Yamaha and Kawasaki over the years. This issue root is the actual plug in most cases. The male and female connectors within the plug tend to vibrate within one another and create a gap. Once the gap issue occurs the AC current begins to Arc from the male to the female metal connectors within the plastic plug. The ensuing heat melts the plug down further aggravating the issue until replacement is required.

If you are now getting 12.6 volts across your system then I would rule out a voltage issue creating your power lag at mid-range throttle.

Power Issue

Your power issue can be a separate issue. The possibilities are the following

  • Mid-range fuel delivery issue in the carburetors. If you put in an aftermarket free flow air filter or an aftermarket exhaust system on your motorcycle you could have leaned out the AFR in the midrange resulting in a lean condition that you experience as power lag at throttle mid-range.

  • Slightly clogged fuel filter would effect fuel delivery but would more than likely be more pronounced at full throttle. If you aren't experiencing full throttle power delivery issues then this is probably not the case. I would clean your petcock filter and replace the fuel filter regardless. It's a common maintenance task and extremely inexpensive.

  • IF you have an aftermarket exhaust and/or air filter you may need to raise your needle a bit. Your needle jet/jet needle relationship dictates your mid range fuel delivery in the venturi of the carburetor. If you have unrestricted the OEM exhaust or air intake you are getting more air and need additional fuel to compensate and get your AFR (Air-fuel Ratio) stoic.

  • Bad battery. You could have wrecked your battery if your rectifier actually failed and not just the plug. When your rectifier fails you get AC current into your system. Your DC battery does not like AC current, it wants DC. A failing battery on a motorcycle cause a litany of issues including (in extreme cases) your RPM gauge moving all over the place and giving clear incorrect readings. Halting power, reduced power at certain RPM's, misfires, etc. If you have a multimeter, you can test your battery. Here is a great post on doing so.

Some Links

There isn't enough information to actually nail down the issue. You will have to do some troubleshooting. IF you have the aftermarket exhaust and/or free flow air filter, feel free to ask what to do to richen up your midrange fuel. Here are some links that might be helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.