4

I have a '98 Ram 1500 and the passenger side tail light has stopped working. Not all of it though. There are two bulbs. One for the reverse light and one that has brake and turn signal as well as the running light. Well the brake and turn signal still works but the running light does not. I changed the bulb still the same problem. I changed the socket still same problem. I also checked all fuses.

  • 1
    Have you checked for continuity and/or ground from the socket? If not, the problem lies closer to the source. You'll more than likely need to trace the wires back to their origin to figure out where you're not getting a connection. My suggestion is to check the ground side out first, as the hot side would be blowing fuses if it were grounded somewhere. – Pᴀᴜʟsᴛᴇʀ2 Aug 26 '16 at 14:31
  • 1
    Do you have a trailer harness wired in? They can be problematic. – Mobius Aug 26 '16 at 15:29
2

Ok, time to get serious here :-)

Do you have access to a test light or a DMM (or a volt meter of any sort)?

It would be good to start by looking at the evidence – if you still have the old bulb, does it look good (clear glass, with both filaments connected to their "arms" on both sides)? Are you sure you've got the right bulb? Has anything happened recently to the truck that is out of the ordinary? Have you added an accessory or driven on a particularly rough road?

Since you replaced the socket, it wouldn't hurt to verify that it is wired correctly. The outer shell should be ground and the two terminals in the base should be the running light and the turn/brake light. Strange things can/will happen if you get that wrong…

Now, with a meter or test light turn on the running lights and turn signal, then check to see if you have voltage present at both of the terminals in the base of the socket (the shell of the socket is ground). One terminal should be on steady and the other should be going on and off. The former is the running lights and the later is the turn signal. Based on what you're saying the turn signal terminal should be going on and off, but the other one should show nothing. But if you do get a voltage at both then you know the problem is with the bulb.

Assuming you get nothing on the running light terminal, check the fuses. Inspect them and also measure the voltage across the fuse terminals in the fuse panel, you should see something close to 12 V with the lights on – if the connection to the tail light is good. With the fuse out you could also try measuring the resistance (Ohms, Ω) between the load side of the fuse (the side which does not show 12 V when the fuse is removed) and ground. You will only see a resistance here if the bulb is installed and good. If you're unsure about the bulb you could have a helper just the running light terminal to ground a test like that. The resistance should be close to zero.

Assuming all of those tests confirm your problem, then you need to start tracing the circuit. That means finding places where you can get to the connections and splices in the wires and open them to check for voltage. To do that a copy of the wiring diagram (schematic) for your specific vehicle really helps. The most likely places for failures will be (roughly in order) the bulb, corrosion in the socket, loose or damaged connectors, a failed switch or relay, or a blown fuse.

If you have a connector for trailer lights that is a potential problem as well – especially if it is not factory. The splice connectors used can damage the wire and some of them are not well sealed so they are a very likely failure point. They are often exposed to physical damage as well.

If you find that it is hard to get access to the wire due to lack of connectors or lack of easy access to the connectors, you could consider pushing a sharp tipped probe through the insulation and into the wire for testing. A bit of electrical tape (or "liquid tape") will ensure that the puncture doesn't become a place for corrosion to set in. If you're doing that try to do a "binary search" – find a place in the middle of the wire to test, if you find voltage there then the problem is "downstream" and you can split that distance in half to do your next check (or vice versa). Doing a binary search helps you to isolate where the problem lies.

To make it simpler to trace the wires make sure you note the size and color of the wire at the socket in the rear. That will help with sorting them wires out in the middle of the run.

0

Check Fuses , check light bulb, and last check for moister in the light bulb housing or check for damages in the wiring harness .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.