3

99 Saturn SC2

Ever since I jumped my car the AC hasn't been working. When I press the AC button the green light will turn on but I don't notice any additional drag on the system like I normally would. I also notice that when I press the recirculate button the air doesn't become more powerful like it used to. Essentially nothing happens at all when I press these buttons.

  • 3
    Perhaps you shorted something out while jumpstarting your car. Have you checked to make sure no fuses are blown? – Dalton D Aug 19 '16 at 14:49
  • 3
    I second @DaltonD here; it's likely to be a blown fuse or relay. Also check that none of the wiring in the engine bay has been disturbed. – Steve Matthews Aug 19 '16 at 14:58
  • We've got a serious allergy to the answer box here, lol. I suppose I'll take one for the team. – Jason C Aug 20 '16 at 8:24
1

Check your fuses.

There's one box near the floor, passenger side, and one under the hood. AC should be in there somewhere but could be another (e.g. maybe a fan fuse, although I suspect the compressor since you're not noticing engine load). There's also an AC relay under the dash, if no fuses are blown, check / swap out that relay.

Make sure you didn't knock any wires loose too, esp. since the car is so old, a fragile connection may have come loose or snapped.

There's always the possibility that another issue with the AC just popped up coincidentally but look for the easy electrical stuff first.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.