3

I have a 2002 Honda Odyssey that has recently developed an annoying habit of having its alarm go off unnecessarily.

There is no discernable pattern for when the alarm goes off - it has happened in several different locations, at different times of the day and different temperatures.

I have owned this car since 2009, but this has only become a problem a month or so ago.

I believe that the alarm is a factory-installed one and not an after-market. When it goes off it honks the horn and flashes the headlights.

I know this is not happening due to accidental actuation of the keyfob - the alarm just went off now and all I have is the physical key - the keyfob is on my wife's keychain several miles away. Having said that I did change the keyfob battery last week, but that didn't help.

The car battery should be OK. It is a nice Interstate-branded battery and is less than 2 years old, and appears to start the engine with no difficulty. (I will get the battery checked out when I get a chance though). Update - I just had the battery checked at the local parts store and apparently its fine.

I have searched google and found that a similar problem is often caused by a faulty hood-latch switch. I used these youtube instructions last night to disconnect this hood-latch switch, but the alarm still went off in the night.

What could be the cause of this and how could it be fixed?


Further info:

  • Currently the SRS light (for airbags) is illuminated on the dashboard while the engine is running. I'm not sure how long this has been the case - normally my wife drives this car. I did get the airbag replaced under the highly-publicised recall a year ago or so.

  • The front bumper came off in a parking-related incident a month ago. Because this is just a daily driver/commuter vehicle we didn't bother with a new bumper, but just had the bodyshop reattach the old bumper (a bit scratched) along with the black plastic covering that goes underneath the radiator area.

3

I have a workaround and its been in place about 6 weeks over 1 year now, so I feel confident to post it.

I left the vehicle with my prefered independent mechanic for two days. Regretfully the alarm didn't go off once in his care :-/

Similarly I took it to my local dealer and had their "alarm specialist" look at it. Again nothing found. But the next day, the alarm still continued its random behaviour.

So my attention turned to disabling the alarm completely. The dealer said this is not possible and the indy mech was unsure. I found some hints online but I think they were for after-market alarms instead of factory-installed.

I played with the hood-activated alarm switch a bit. This switch is normally closed when the hood is open and open when the hood is closed. It turns out that if the switch is permanently closed (i.e. the alarm thinks the hood is open), then the alarm does not get armed. I was able to test this by:

  1. observing the red flashing LED on the dashboard - this only flashes when the alarm is armed and is off otherwise.

  2. faking out a door switch. If the driver's door is held open and the door push switch is manually held in the pushed position and the door is locked, then the alarm is armed after 10 seconds or so. If I then release the door push switch, then the alarm goes off as expected.

My fix is simple:

  1. Disconnect the hood switch connector as per the OP youtube clip

  2. Cut and bend a paperclip and insert into the two contacts in the hood switch connector socket to make them always connected.

This makes the alarm system think that the hood is open and it never arms the alarm. I verified this using the two tests listed above. The alarm has now not gone off for 6 weeks.

2

In my car, the reason for the alarm going off randomly was water leaking from the "body seam" on the roof, through the left front pillar, and zapping the computer.

  • A cause someone else had was a large moth or cricket waking up (coming out of hiding) and setting off the alarm!! – Solar Mike Jul 28 '17 at 5:16
2

We were dealing with a similar problem with a 2003 Odyssey. We watched the YouTube video and disconnected the hood switch connector, and the problem was improved for several months. Out of nowhere the alarm started going off when opening the door, turning on/off the ignition. The red flashing "alarm" light was clearly visible on the dash.

I took the car to Honda and they told me that if the car is locked via the remote lock, and unlocked via key, it disrupts the circuit and the circuit must be reset. They said to unlock and relock the door manually using the key in the door lock, and then unlock and relock the door using the remote. When they did this, the flashing alarm light turned off and the alarm hasn't gone off since.

Hope sharing this helps someone else because I'd never heard this before!

1

Here is the wiring diagram and all sensors (switches) that could be faulty. You could disconnect the connector from the Drivers Mutiplex Control Unit and test the sensors wires to ground, there should be no continuity to ground with all doors, hood closed. Unfortunately I don't have a location for it.

enter image description here

  • 1
    Not sure if I can identify the DCMU right now, so instead I've disconnected the switches for the hood, the tailgate and all 4 doors, so all of these circuits are forced open. I've locked the car. Lets see what happens with the alarm now... – Digital Trauma Aug 11 '16 at 23:51
  • If it cure it connect one at a time and test to find the culprit. – Moab Aug 12 '16 at 0:10
  • Sadly not - the alarm just went off again :-/ – Digital Trauma Aug 12 '16 at 0:14
  • @DigitalTrauma The multiplex unit is the under dash fuse box. – Ben Aug 12 '16 at 1:14
  • Thanks @Ben. I'm still trying to find it. here's a photo of the fusebox. I assume I'm looking for something like this – Digital Trauma Aug 14 '16 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.