18

I've found a number of apps for the iPhone/iPad that connect to ODB-II readers via WiFi, but unfortunately that means that it disables 3G and all the benefits of having a 3G device built into my dash.

I can't seem to find any apps that work via Bluetooth instead of WiFi.

Do any of you know if there is one available?

  • Devices wanting to communicate data over Bluetooth with an iOS device must get an authentication coprocessor through Apple's MFi program, which anecdotally is not easy or cheap to join. Three I've found are Automatic, GoPoint BT1, and Xtool. I'm not sure they all use ELM327, particularly Automatic, though Automatic does have third party apps. (Can't leave as answer due to lack of rep.) – duozmo Sep 16 '15 at 3:05
  • You need a BlueTooth LE (BTLE) (4.0) device like LELink or Carista. BTLE does not use profiles like regular BT and for OBDII devices, connects without authentication (yikes). I have the LELink and using OBD Fusion via BTLE… works great. Can't help but wonder if people won't try to bit-jack my car as I drive by 🤔. Here is the app (impressive human interface) : bit.ly/2i3g0Px – William Cerniuk Jan 2 '17 at 19:47
11

ELM327 is not supported by iPhone as Apples Bluetooth Stack does not support the Bluetooth Serial protocol, the ELM327 is in it's simplest form a ODB to Serial Adapter with the serial data fed to a Bluetooth modem.

  • 1
    I should have found this before buying the adapter. – sorin Nov 10 '11 at 22:03
4

Well, It's not necessarily dealing with the ELM327, but this looks like a FANTASTIC solution.
Griffin CarTrip

No longer getting developed.


Apple is currently not allowing developers to use Bluetooth for this purpose. The only real connection is via Wifi.

My initial "assumption" was that if you're connected via Wifi, then your 3G data is disabled and therefore you cannot use data while using the OBD-II dongle. This information is wrong. If you put your data connection in proxy mode, your phone will still connect to data through 3G, even when connected to the dongle.

This works very well except for the minor issue whereby the gauges poll once every second as opposed to constantly polling in real time with what's actually happening. This makes for a choppy user experience, but it still works well.

  • Was this link redirected or is just spam to a shop? – sorin Nov 10 '11 at 22:02
  • 1
    No, sorry. Looks like the CarTrip is currently OUT of development. If you look on their blog, they've said they're currently not working on it... they just pulled it right out of their site. – Chase Florell Nov 10 '11 at 22:04
  • Ended up buying the ELM327 WiFi module and Rev2 – Chase Florell May 4 '12 at 1:23
3

Apple will not let you connect to the ELM 327 Bluetooth Interface as the manufacturer has not paid APPLE to support their bluetooth stack. Gotta Love EM'

There are plenty of apps for the Android that work well with the ELM 327 Bluetooth modules.

  • What was the PIN for your ELM 327 module? – sorin Nov 11 '11 at 7:49
  • I ended up buying the ELM327 WiFi module and Rev2 – Chase Florell May 4 '12 at 1:24
1

The accepted answer describes the situation as of iOS 5 and below.

Since 2014, iOS comes with the CoreBluetooth framework which allows communication with BTLE (Bluetooth Low Energy aka 4.0) devices. These days, you can find a lot of adapters supporting this communication standard – make sure that it is not a Bluetooth 3.x adapter, these will not work.

As for iOS applications, unfortunately not many do support BTLE yet at all. Those which do mostly require their branded adapter. There are only a few which claim to work with almost any BTLE-compliant adapter, e.g. OBD2 Expert (Disclaimer: I'm the author).

  • This should be the new accepted answer. What ELM 327-device are you, personally, using? – d-b Sep 30 at 14:43
  • @d-b I prefer Carista BTLE and LELINK BTLE adapters. Unfortunately neither of them has an original ELM327, they're all using clones :-( – DrMickeyLauer Oct 5 at 17:01
  • I bought a VGate iCar Pro with BT 4.0 which I think is authentic ELM 327. – d-b Oct 5 at 18:46

protected by Community Nov 14 '11 at 21:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.