4

Walked by my parked 2009 Flex in driveway. The radio was playing!! I unlocked it, lo and behold, all the dashboard lights are flickering on and off, I can move the shifter, the bell is dinging like the key is in the ignition, and the throttle body is clicking away like crazy under the hood. I had to disconnect battery to get it to stop. Went and bought a new battery the next day (a hail mary), did not alleviate the problem.

The first shop couldn't get it to replicate so I picked it up, drove it to work, and it wouldnt start anymore, in addition to all the aforementioned problems.(Battery was not dead, good charge still)

Second shop diagnosed a bad smart junction box ($600 repair), car starts up great, problemseems to be solved, but next day I walk by my car in driveway, and.... radio is playing!! Same exact problem still happening. Super sad face.

Any ideas as to what it could BE?

  • Have you had any water leaks? – dlu Jul 28 '16 at 5:42
  • Even if you haven't noticed a leak, has it been raining when it happens? – HandyHowie Jul 28 '16 at 7:26
  • There has been a thunderstorm here or there, and I did take it through the car wash once, but there hasn't been a lot of rain and not in days. Obviously the SJB wasn't the source of the problem, what else do you think it could be? I kept suggesting ignition switch, as it behaves like the key is in the ignition at times, (able to shift ignition, bell dinging) but that doesn't explain throttle body clicking and dashboard lights flashing – ss734 Jul 29 '16 at 14:25
  • So the update is the electrical problems seem to be gone. So I guess the smart junction box was the problem. Or maybe it was wet somewhere, and dried out. Now I'm afraid to wash my car. – ss734 Aug 4 '16 at 2:30
  • So I took my Flex through an automatic car wash, after not washing it for a few weeks. I park it for 2 hours, come out, guess freaking what. I go to unlock my car and the radio is playing, the bell is dinging when I open the door, lights are flashing, the car won't start. So I guess it is a moisture problem. Had to get it towed. SUPER SAD FACE!!!!!! – ss734 Aug 9 '16 at 6:59

protected by Community Dec 9 '18 at 2:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.