3

I can't get it to fully open wide and run. 2013 model, any help would be great.

P.S. had a 80 cc modification done and also the jets were upgraded as needed. I'm thinking all my air hoses are out of position

Thanks in advance.

  • 1
    Welcome to the site. To confirm if the hoses are where they should be, I suggest uploading some pictures. You can edit them into the question. – Zaid Jul 9 '16 at 10:24
  • I would check to ensure proper operation of the choke if so equipped. Also, while you suggest the "air hoses are out of position", double check to ensure there aren't any obstructions within them and that none are crimped. It sounds as though the air passages are blocked somehome. – Pᴀᴜʟsᴛᴇʀ2 Jul 9 '16 at 11:38
  • Make sure your choke works. If you upgrade your engine by increasing a capacity (50cc to 80cc) it should work okay with original carburetor and jet. It is better to replace a carburetor to a bigger one for more power at high revs, but if you are looking for problems - try to put back original jet. And did you put bigger or smaller jet? There should be a number on a jet like 50 55 60 65... Also you can try to warm it up without reving (3 minutes) and see how it behaves then. Do you have a original oil mix system? Or you mix it with fuel manually? – Arturs Bolsunovskis Jul 9 '16 at 18:10
  • thank you Sir, Couldn't find the old jet,to see the number it had,however it was recommended by scrappy dog scooters, to use the larger sized to replace the 50cc one, the choke may just be the problem also runs rich and exhausty like it is 'vapor lock smell', that I used to get on my Datsun 240Z, before having replaced the carbs. the oil is separate from the gastank, meaning that each have their own ressavore. thanks again – Michael Calloway Jul 10 '16 at 7:23
  • Does it always run rich or only during warm up? – rpmerf Jul 11 '16 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.