3

I have a 2005 Chevrolet Impala (Base trim, 3.4L) and I recently purchased a cheap OBD2 Bluetooth reader. Unfortunately, Torque (Android app) isn't able to read data from this transmitter when connected to my Impala. I tried it on my 2006 Ford Freestlye and it works very well.

The transmitter lights up and looks like it is functioning properly, but I'm not able to read with the Torque app. I tried another app and it gave a message saying "Cannot query engine rpm."

I'd really appreciate anyone who can tell me some troubleshooting steps. Perhaps GM has a different sub-protocol or something that I don't know about. I'm happy to add information if I left something out. Thanks!

  • Can the app do anything like read trouble codes or does it not work at all? Do you have access to a basic code scanner to see if that works? – JPhi1618 Jun 17 '16 at 19:25
  • Update: I downloaded Torque Pro and tried again. It gives more connection info. It appears i can connect to the reader just fine, but the connection to the ECU is not available. Not sure why its not working. – trademark Jun 17 '16 at 20:39
  • 2
    Having a SnapOn Modus with domsestic, euro, and asian software, a drawer full of basic OBD II scan tools (I'm a big Autel fan)... I bought the same "blootoowf" crap off Groupon. It would not speak certain odd profiles with my older Subarus. It worked well on my GF's Toyota Sienna, but was useless on some other vehicles. That "Torque" cellphone software is not fully realized. [My opinion] – SteveRacer Jun 18 '16 at 4:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.