1

2003 Mercury Sable

When accelerating from stop sign, red light, attempting to get on the highway the car has no power when applying pressure to the gas pedal. Struggling to get past 20-25 mph. Once I release pressure on the gas pedal the car will get up to 35 mph and will run fine gaining speed and going 60 mph with no problem. When I come upon a red light or stop sign again it does the same thing.

  • Do you have access to a scantool that can read live data? Check engine light on? Any misfiring? If you lock it in 2 or 3 and rev the car higher does it still hesitate? – Ben Jun 4 '16 at 20:27
  • Fuel pressure/volume - might be as simple as a clogged fuel filter... But that's an early KISS (KeepItSimpleSilly) guess that would be a likely expanation, but there are many more. If there's a CheckEngineLight or "SES" (Ford lingo), as Ben indicates those codes behind the light are a great start in narrowing down the specifics. Me, I'd replace the fuel filter as a starting point, because it's so inexpensive to do, and perhaps hasn't been done -- and needs to be done even if it's not the ultimate solution. – SteveRacer Jun 4 '16 at 20:50
  • No check engine light comes on.However,if i try to merge onto highway and give it gas it has no power at all barely 25 mph and check engine light will come on but once i take my foot off gas pedal it goes out and does not comes back on. It does miss but when i get up to 25-30 mph and don't apply pressure to gas pedal it runs perfect until i get to stop sign or red light.. No stalling, car starts first time every time cold or warm weather.No over heating. Replaced 1 oxygen sensor and mass air flow sensor. Still acts up at red light & stop signs. i guess i will try tune up and gas filter. – Scott Lowman Jun 27 '16 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.