I have a 1999 Subaru Forester with an automatic transmission and a 2.5 Liter Motor. It has poor acceleration and rough shifting

I started to notice 'hesitation' on take off. It just slowly appeared. Then I realized if I was trying to pass someone at speed, 40 to 60 mph, it would actually slow down when I pressed the gas pedal harder. I increase speed by backing off the throttle. It had an 02 code that didn't affect the driving for a couple years now. I thought it might be a TPS issue so I changed that out and still the same issue persists.

I decided to swap the throttle body out and had an issue with the old gasket. So I replaced that gasket and installed the old throttle body back on just to see. My 02 code went away but it still runs like crap. its not possible to do any fast accelerating at all. It needs to slowly reach speed and if you try to go too hard on the gas pedal it will just bog down and semi stall until you back off the throttle and find its 'sweet spot' where it will start to accelerate again.

With my Snap-On scan tool plugged in I am getting an STFT of about 22% to 37% when engine is good and warmed up. The LTFT is between 25% to 30% at an easy cruising speed around 2600 RPM. When I push the throttle to the floor at speed STFT will go to a -10% area and the LTFT will go to around -5%. As soon as I let off the throttle it finds its 'sweet spot' again so it can accelerate. They both go back to what they were prior. Ignition advance is around 15 degrees and will climb to around 30 or so.

I have:

  • New NGK plugs

  • New fuel filter with 28 to 33 pounds of fuel pressure.

Any ideas before I start pulling injectors and checking and cleaning each of those today?

  • and yes as for the bad shifting, that is a kick down thing from the tsp not being placed quite right. that am not to concerned about or isnt as important as this issue... Commented May 26, 2016 at 20:40
  • 2
    tsp? did you mean tps? throttle position is pretty important. how is it not placed right? fuel pressure looks about right. what was the maf doing during your tests? what are fuel trims at idle? i'd say you either have a vacuum leak or the maf is under reporting. fuel injector failure on subarus is pretty rare. what are the o2 sensors doing? can you force lean and rich conditions to confirm range?
    – Ben
    Commented May 26, 2016 at 21:08
  • @SteveMcdaniel Please add any fault codes. The O2 codes could be a clue. As Ben noted there are lots possible causes. A failed Air Fuel Ratio sensor can also cause these symptoms and fuel trim readings. Commented May 26, 2016 at 22:02
  • well since replacing the throttle body gasket there have been no codes. prior to fixing that issue i had a 02 code but it was cleared up by fixing the intake gasket leak wich was a bad vaccuum leak. now there are no codes at all, and no vacuum leaks at all anywhere, that i promise. Commented May 26, 2016 at 22:27
  • and yes i meant throttle position sensor instead of tsp. and as for it being placed right, to far one direction and the AT oil temp light comes on and it is real bad trying to shift. going the other way it just looses all ummmm 'balls' no i can not force lean / rich conditions. the only thing i am reading on them is the voltage and it is in range.fuel trim at idle is about 7 to 10 on short term and long is normaly about 0 at idle but it does jump on occasion. Commented May 26, 2016 at 22:32

3 Answers 3


I'm leaning towards the throttle position sensor being out of adjustment/bad or a bad mass airflow sensor.

Perform a volumetric efficiency test, record your IAT in °F, RPM and MAF in g/s. Use an online calculator like https://www.otctools.com/ve. You may want to do multiple pulls to get an average.

TPS voltage at idle should be around .5v and at wide open throttle should be around 4.5v. Key on engine off should be 5v. Perform a sweep test on the TPS to verify there aren't any drop outs.

Some other PIDs you should look at are MAP and BARO make sure BARO is correct for your area.


so after pulling and checking each injector and reading all i could about this kinda thing, i found a few brief reference about the vehicle going into a 'safe mode', well that made me curious, because it sounded like what i had going on. so i just decided to unhook the battery for a awhile then try it. well it was running even rougher at start up after that, just struggling to stay running going from a real low idle to a very high one and really 'chuggin' as i am trying to keep it running by 'feathering' the throttle. then it came to me, i unhooked battery again and later when i restarted it, it was running rough, exactly the same, really. but this time i did not touch the throttle i just let it keepo corrrecting itself, then after a few minutes it actualy started to smooth out a few minutes later i was pulling out on a test drive. was it 65 mph in a blink of a eye, and i realized at that moment i had found the CURE. all it needed was a chance to fix itself lmao ya right i dont buy that crap either

  • Limp mode is a real thing. While this might have reset your ECU for now, you should try to track down what put you in limp mode to begin with.
    – Bob Cross
    Commented Sep 19, 2016 at 12:09

I had a friend have this issue and kept going into limp mode and I found her connector for the knock sensor was faulty and losing connection and when it did it would run horrible and even die out and have a hard time starting, I rewired the connector and it solved her issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .