7

I recently swapped my Kenwood stereo for a new one, also Kenwood. As the adapter was the same it was relatively easy to swap them over.

Everything was fine for a day. However, the unit always asks to choose a language and whether to stay in demo mode. Saved radio stations remain.

I then took the unit out again to disconnect and reconnect to see if any issues could be resolved. But now there is no power. I have checked the cables and it looks fine. I have also changed the relevant fuse (42) but still nothing. I tried my old stereo and that doesn't work either. I know nothing is wrong with the new stereo as I have had it checked in a shop.

I have been advised that changing round the red and yellow cables on the stereo may fix the resets but I still have the issue of no power.

  • 4
    Did you check if you are getting 12V at the red and yellow cables with a multimeter? Maybe you pulled the cable and broke it. Or the adapter broke inside. – race fever Apr 23 '16 at 16:16
  • 3
    There should be two fuses that affect the stereo. One provides the main power, the other provides accessory power, which only has power when the vehicle is on or in accessory mode. The stereo needs power from both to turn on. You could have damaged the connector or a wire when you disconnected it, or you could have a different fuse causing the issue. – Paul Dufresne Apr 24 '16 at 4:09
  • @PaulDufresne - Write this as an answer ... I think you're spot on. – Pᴀᴜʟsᴛᴇʀ2 Oct 6 '16 at 19:17
1

There should be two fuses that affect the stereo. One provides the main power, the other provides accessory power, which only has power when the vehicle is on or in accessory mode. The stereo needs power from both to turn on. You could have damaged the connector or a wire when you disconnected it, or you could have a different fuse causing the issue.

NOTE: This answer is copied from comments located below the question in an attempt to get this question answered.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.