After travelling 7-8km on my Royal Enfield Classic 350, the bike acts as if the fuel is finished & the engine shuts down, but it starts again when I pull the accelerator.

What could cause this behavior? Could it be the carburetor?

2 Answers 2


IMO you have a fuel starved vehicle. Perhaps some blockage in the gas tank at the petcock filter or an inline filter between your gas tank and the carburetor.

When you run the bike the fuel might not be filling the float bowl at the rate that the engine is consuming fuel. When your bike stalls the fuel is trickling into the float bowl and then you can start it again.

I would take your petcock out and thoroughly clean it as well as clean any inline fuel filters you have and see if you can get any silt or debris out the fuel system.

If you do have lots of silt or debris you would want to remove the carburetor and clean it all out with pressurized carburetor cleaner to squirt out the jets, but that's ancillary in my opinion.

It's sounds like fuel starvation from my PoV. Clean out/replace any/all fuel filters in your system.

Good luck!

  • Maybe the engine idle RPM (which can be manually set in RE Classic) is set too low? That might also be a reason.
    – kgkmeekg
    Commented Mar 28, 2016 at 3:13
  • The bike doesn't run after 7-8km of riding but after it stalls a moment it runs fine. I don't see the connection between idle and that type of issue. Can you explain how the idle being set low could create that condition? Commented Mar 28, 2016 at 4:05
  • Fuel tank, filter & carburetor has been cleaned. Fuel pipe is changed but still the same problem.
    – pramaze
    Commented Mar 28, 2016 at 5:36
  • @DucatiKiller in RE the idle rpm is controlled by a knob which is directly connected to the oil flow control. Hence my guess. Although my bike is a different manufacturer has similar mechanism. I have made this observation in mine. Not that it always solves the problem, but wouldn't harm to check. Right?
    – kgkmeekg
    Commented Mar 28, 2016 at 14:35
  • Also check that the fuel cap vent is working correctly
    – r.anderson
    Commented Jan 15, 2018 at 15:51

That's fuel starvation. Common with carbs and gravity feed. Your enfield has a vacuum petcock. If cleaning fuel filters doesn't work try another Percocet setting. You may have off, on, reserve. Or you might have a 'prime'

If you have a prime setting try switching to that. It doesn't use the vacuum to allow fuel to flow. Try driving on that setting. If it solves the problem then you either have a bad petcock diaphragm or a vacuum leak on the vacuum line from your manifold to the petcock.

  • That's a very good point you make. I'm a little ashamed that I didn't think of it myself. Commented Mar 30, 2016 at 1:25
  • What i found is the bike is the ignition coil is not giving enought spark to the spark plug. So whats the reason behind that???
    – pramaze
    Commented Mar 30, 2016 at 19:20
  • How do you know that? Commented Mar 31, 2016 at 1:10
  • Checked with my frens bike...sparks arent lik his on mine....so the mechanic told "pulsar coil" must be replaced
    – pramaze
    Commented Mar 31, 2016 at 9:31
  • Thanks guys for ur time n suggestion. I replaced the magnet coil....because it was not working the battery was not getting charge while the engine was running. Problem solved running gr8.
    – pramaze
    Commented Apr 1, 2016 at 13:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .