5

I have 1999 V10 Ford chassis on a 2000 Coachman motorhome. Engine starts great when cold, runs great, idles great, no skipping, missing, etc. Problem is that after driving more than 30 minutes or so it won't start, cranks but will not start until it has set long enough to get cold again. Computer code says lean fuel. Mechanic who ran codes had no idea as he checked and I heard him tell his coworker that it was getting plenty of fuel. Please help.

  • If you let it run, will it continue to run without issue? Exactly which lean code are you getting (actual code)? – Pᴀᴜʟsᴛᴇʀ2 Mar 25 '16 at 17:46
  • Yes, runs without issue all day. I do not turn it off until I get to where I will be parked for the night. Once turned off it will not start again until next morning. Then it starts right up without delay. I don't know exact code. I paid a truck repair shop $100 to run computer on it and lean fuel was all they told me. – Jan Friend Mar 25 '16 at 18:14
  • It runs great, accelerates great, I can let it idle while I shop or eat up to as long as an hour, and get in put in drive and take off without problem, but if I turn off, I am stranded until motor completely cools....2 or 3 hours or longer on a very hot day. – Jan Friend Mar 25 '16 at 18:27
  • When you crank it over and it won't start, does it seem like it wants to start at all, or does it just crank over with no other signs of life? – Pᴀᴜʟsᴛᴇʀ2 Mar 25 '16 at 19:40
  • Go get a code reader. They are pretty cheap. Autozone will read codes for you for free (but not sure if your vehicle will qualify for that.) We really need the actual code number. The won't restart-when-hot sounds like old school fuel vapor lockup, but that shouldn't happen with a modern engine with in-tank electric fuel pump and fuel injection. Maybe fuel pressure regulator is kaput? (Not sure about that model year's systems....) – zipzit Mar 25 '16 at 19:57
4

In fuel-injected systems, hot-start problems indicate that the fuel line is unable to maintain pressure.

This could be due to a few things related to the fuel supply line, including:

  • a leaky fuel injector
  • minute cracks in the fuel line which leak fuel when under pressure
  • a bad non-return valve in the fuel line which is allowing pressurized fuel to flow backwards

The reason why this happens only for hot starts is because the fuel is more likely to vaporize as temperature increases. In order to avoid vaporization problems the fuel lines are expected to be pressurized during a hot start.

  • Thanks for all the suggestions. The only one the truck mechanic offered was a bad fuel pump but because it runs so good it just does not sound like a fuel pump to me. It may be old but only has 40,000 miles on it. It is in shop now having the roof repaired from storm damage. When I get it back I will see about getting specific codes. Thanks again for your help. Being a semi old widow, I know I can be taken advantage of, and cannot afford a fuel pump if that is not the problem. – Jan Friend Mar 25 '16 at 21:21
  • 1
    @JanFriend if it were a fuel pump, I would expect a different set of symptoms such as the engine sputtering under high loads (like when going uphill, high rpm's), but based on your description of how the vehicle runs I'm not sure that is the case here. May I suggest you invest in a generic OBDII scanner for extracting the codes? They're relatively cheap and pay for themselves when used even a few times. – Zaid Mar 25 '16 at 21:52
  • An OBDII scanner would make sense if I knew what it is and how to use it!! haha. Unfortunately, I have to depend on the "professionals". I just know what I read on the internet about the symptons of a bad fuel pump and know my rv doesn't have them. – Jan Friend Mar 25 '16 at 22:10
  • Dont forget that around this time when they first started using electric in tank fuel pumps they didn't have great fuel pump pressure controls (On later models the fuel pump controller used Pulsed Width Modulation to control fuel pressure...) They used to use a fuel pressure regulator at the engine, and any excess fuel they'd route back to the fuel tank with the fuel return line (a second hose). If that regulator goes bad you could get low pressure (which leads to fuel vapor lock). Remember the hottest engine temperatures are observed 10 minutes after you shut the vehicle off. – zipzit Mar 26 '16 at 9:12
0

Jan, I also have a V10 with the exact same problem which I haven't remedied yet but I have figured out a simple answer around the problem. Cycle the ignition switch (key) off and on two or three times (without engaging the starter) and in doing so the fuel pump will force the fuel rail to fill with fuel and then turn the key to start the motor.....it works every time, no matter if the engine is hot or not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.