3

I have a 89 camaro I personally don't think it's a fuel pump issue and I recently changed the relay, but whenever I turn the key over sometimes I hear the fuel pump turn on sometimes I don't. Could it be a bad sensor or possible the fuel pump if I'm wrong?

Added from comments/answers:

Update 1: The car stalls while driving but usually cranks right back up but now it doesn't at all

Update 2: If the fuel pump not giving enough pressure do I have to replace it?

Update 3: Yes it's OBD1 it's just been sitting there for so long and I've been trying to solve the problem myself, I'm just gonna take it to a mechanic.

  • What problem are you experiencing, other than a quiet pump? – HandyHowie Mar 15 '16 at 9:28
  • The pump not quiet just turns on when it wants to,thats the only problem I have with it that I know of – PrynceCharmng Mar 15 '16 at 9:51
  • So the engine is running correctly. – HandyHowie Mar 15 '16 at 9:59
  • Yes the engine cranks and thanks something told me to try that just wanted to be 100% sure, so even if the car cuts off while being driven could that also solve the problem? – PrynceCharmng Mar 15 '16 at 18:27
  • So is the car stalling while driving? Or you just don't hear the pump come on sometimes but it still starts? – Ben Mar 15 '16 at 19:46
5

On most fuel injected cars where you can hear the pump turn on, once the system is up to pressure, the pump won't re-engage until it needs to. One easy way to test this is to turn the car on, but don't start, first thing in the morning. If you hear the pump, good thus far. Next, tap the key over to just barely engage the starter, but not enough to start the engine. You should hear the pump kick in every time you do this. If you don't hear it, you have an issue.

If you really want to check your fuel pump, put a fuel pressure gauge on the fuel rail (back passenger side). This is really hard to do on the TPI system, because the plenum sits right over the top of the Schraeder valve. You'll need an elbow fitting to attach to the rail. Pressure should be about 43.5psi without the engine started, but key on. It will be about 5-10psi lower while running at idle (IIRC).

  • This does sound like all the 'problem' is. It wasn't clear if the OP was originally suggesting the engine wouldn't start. – HandyHowie Mar 15 '16 at 12:12
  • @HandyHowie - Agreed. – Pᴀᴜʟsᴛᴇʀ2 Mar 15 '16 at 14:14
  • @ᴘᴀᴜʟsᴛᴇʀ2 May I add something here? You don't need to mount a gauge to check your fuel pump if your system works with fuel return. Considering that your pressure regulator (attached to your fuel rail) is working properly, if you remove the fuel return pipe from the tank, and your pump is producing enough pressure, you'll notice fuel flow through it. If no fuel comes out of it your pump is not producing enough pressure. – PDuarte Mar 18 '16 at 0:23
1

So first off you need to verify fuel pressure like paulster2 said.

If you don't have fuel pressure it's time to check the relay wiring.

Key On Engine Off

At the relay there should be battery voltage (12+V) on pin 5 (orange) If you don't have battery voltage on this wire check the fuses and check the connection to the battery positive terminal.

On pin 3 (dark green/white) there will be 12 volts coming from the PCM to power the relay coil. And pin 2 (black/white) will be the relay coil ground.

Pin 1 (tan/white) is the wire that sends battery voltage to the fuel pump, MAF relay etc...

On your Camaro if for some reason the fuel pump relay fails oil pressure from cranking closes the oil pressure switch and provides power to the fuel pump circuit as a backup.

So in the case of no fuel pressure. Either the fuel pump is bad/on it's way out, the wiring to the pump doesn't have continuity, or the wiring to the battery doesn't have continuity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.