4

Disclaimer: I have very little electrical knowledge.

I have wired electronics (radar detectors, dash cameras, GPS units, etc.) to about a dozen vehicles in the past, but have ran into a strange issue with my 2016 Toyota Tacoma (which, I'm told, uses Can Bus).

I've found a switched 12V source (sensor on brake fluid reservoir); verified using a multimeter. 12v when the truck is running, 0 when it's off. I've spliced in a 12V accessory, and at this point the voltage dropped to 5V. If I disconnect my accessory's ground, the voltage goes back up to 12V.

I have tried numerous grounding locations for my accessory - does not seem to make a difference.

This appears to be the only easily-accessible, switched 12V source where I'm looking (engine bay), and I'd rather not run cables through the firewall to an in-cabin source.

What do I need to do in order to have my accessory run off this 12V source?

I'm guessing I could wire my accessory to the truck's battery via a relay, and use the switched 12V to control the relay, but I've never done that, so it's just a guess. I would prefer to avoid such complications, if possible.

migrated from electronics.stackexchange.com Mar 3 '16 at 4:28

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

  • Could you please provide more info on the switched 12v source? – laptop2d Mar 2 '16 at 23:09
  • @laptop2d - What kind of info are you looking for? It's a fluid-level sensor on the brake fluid reservoir. Two wires - 12V and ground. – Yuriy Babenko Mar 2 '16 at 23:13
  • 1
    Probably it is protected by some kind of electronic current limiting device, it is not just connected to 12V with wires. – Marko Buršič Mar 2 '16 at 23:25
  • 1
    I suggest that you keep away from breaking and other safety relevant wiring just for your peace of mind and future insurance liability possibilities. The answer below is likely correct. – KalleMP Mar 2 '16 at 23:34
  • 1
    For the most part most of the relays are switched with the ignition on Acc. A wiring diagram is crucial, but you may want to try a specialty website forum like Tacomaworld or ToyotaNation to ask for specifics on which relay may be good to tap. Some of them have access to the 3rd Gen Tacoma service manuals. The Engine Main Relay comes to mind though. – cde Mar 3 '16 at 0:56
8

I think the comment reveals the problem: you've tapped a sensor wire on the brake fluid reservoir. Could it be that the 12V supply is routed through a red lamp on the dashboard that lights up when the sensor sees low level and connects the wire to ground? If that's the case, it would measure as 12V on the multimeter, via the un-lit bulb (low resistance). Your accessory draws some current (to ground) via the bulb and the voltage drops to 5V. Maybe the bulb glows dimly on the dashboard. The multimeter does not draw enough current (almost none at all) to light the bulb or to drop any voltage across it.

I think you'll need to find another place to tap off a switched 12V supply.

  • Thanks, John Honniball. Interestingly, disconnecting the sensor altogether does not trigger any lights or warnings on the car. Perhaps I need to actually drive it with the sensor disconnected in order for that to happen (I've only been running it while parked). Also, I've encountered exactly the same 12V->5V drop with another switched 12V wire in the dome-light area (I was wiring other accessories, and ended up connecting them to a different switched 12V in the same area - which worked as expected). – Yuriy Babenko Mar 2 '16 at 23:47
  • It could very well be that the sensor in the brake fluid reservoir connects its 12 volt input to ground when fluid is low and that connection triggers the alarm/turns on the dash lamp. To check if that's the case, connect your accessory again (since it doesn't seem to hurt anything) and look to see if the warning lamp comes on. – EM Fields Mar 3 '16 at 0:21
2

Did more research on this and the consensus seems to be that Tacoma's electronics detect the additional current (of the accessory), and drop the voltage automatically as some sort of safety/precaution mechanism. No alerts/lights/errors as a result of this, though.

I ended up using an add-a-circuit fuse tap to tap a switched fuse in the engine's fuse block.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.