3

Escort runs great with heater or a/c on. It runs rough and sometimes dies when they're off. What could be the problem?

  • Which fuel does the engine use? – HandyHowie Feb 3 '16 at 19:16
  • When you say the heater is on, you mean that the dial was turned away from "A/C" and "Max A/C"? Was it turned to either the defrost or defrost/feet setting? I'm basing my question off this pic of a '98 Escort. If it was turned to either of those, the A/C may have "secretly" been on because it helps with defrosting. – Zach Mierzejewski Feb 3 '16 at 19:27
  • 1
    Possible duplicate of - mechanics.stackexchange.com/questions/22851/… – HandyHowie Feb 3 '16 at 20:34
  • Welcome to Motor Vehicle Maintenance and Repair Jim, we're glad you're here. Something to keep in mind when asking a question is to give as much specific information about the symptoms of the problem, as well as as much information about your specific car as you can. Make, model, year, mileage, what recent work was done on it, etc.. That will really help the community to help you. – cdunn Feb 3 '16 at 20:39
1

Kind of a shot in the dark with the information given, but here is where I would start..

When you have the A/C on, the ECU will typically raise the idle to compensate for the extra load. I am thinking you have a dirty throttle body, that is not allowing enough air to get through to allow it to idle properly. When the ECU raises the idle, it is now letting enough air in to idle properly. I would clean the throttle body with carb cleaner and a toothbrush. There is likely a ring of carbon around where the butterfly valve closes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy