6

When I first started having the problem the airbag light started flashing, after a week or so airbag light stayed on. When ignition is on for two minutes I get five (5) beeps Five (5) times for a total of 25. After 30 minutes or so the beeping will start again.

Thanks for your help.

  • Is the check engine light on as well? Are there any codes being thrown by your Engine Control Unit (ECU)? – cdunn Jan 21 '16 at 17:59
  • Have the airbags ever been deployed? If so were they replaced? Could be a bad or needing to be reset SRS module. – Dee Jan 21 '16 at 18:56
  • No check engine light, bag has never been deployed. – GeneM Jan 22 '16 at 4:34
2

The Escapes are known to have an issue with the seat connection on the passenger side. This is the connection which goes to the seat to see if someone is sitting in the seat (if nobody's in the seat, the pass side air bag won't deploy). Under the seat there is a wire which will go down from the seat bottom to about the middle underneath of it. Try to see if pulling this apart and putting it back together has any affect on the bag light. It's the connector itself which has the issue, so inspect the connectors on both sides to see if you can tell an obvious issue. You might also try to jump the two wires from one connector to the other. The "easy" fix (if there is an issue here) is to remove the connector and connect the two wires directly to their mates (from seat to floor, not the two floor or two seat wires together).

  • Removed seat and carefully checked all connections, especially one mentioned under the seat. Light remains on with beeping sequence. – GeneM Jan 22 '16 at 17:35
  • You'll need to get the air-bag codes read then. – Pᴀᴜʟsᴛᴇʀ2 Jan 22 '16 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.