11

When getting my battery tested for an issue in this post, the mechanic noted that when my Ford's "quickclear" windscreen heating element was activated and the engine running, the voltage coming from the battery dips, whereas this doesn't happen with other accessories.

The voltage dipped and continued to decrease. You could see the headlights dim, and if the blowers were on the speed decreased as you could tell by the sound. Using another accessory, for example the rear window heater only caused a momentary dip, and then the voltage stabilised.

Is this normal behaviour for the heated windscreen? The mechanic was convinced this was abnormal and should be looked at. Also, if there is a fault with the windscreen, is this likely to cause any battery drain when the car is off?

5

There won't be a fault with the windscreen. If it was drawing excessive current, then the fuse for this circuit would blow.

There could possibly be a fault with you alternator, in that it is not able to provide the current being drawn by the windscreen, this will then cause the battery to discharge.

Another possibility is that the idle speed control valve is not keeping the engine revs at the normal idle speed. This may cause the alternator to not provide the required current for the windscreen heater, so once again, the battery will discharge. Do the engine revs drop when you turn on the windscreen heater? (You can ignore this last section if your car is a diesel)

Does the voltage increase again if you rev the engine?

  • Or, it might be the case that the alternator simply can't provide enough power at idle even when operating normally and the extra power is supposed to come from the battery. If the battery is failing, this might explain the voltage dip. Heated windshields typically use quite large amounts of current. My understanding is that it's around 30 amperes total (there are probably two fuses, one for left side and the other for right side of the windshield). Heating time on my RAV4 windshield is limited to 5 minutes, so it's at most 2.5 ampere hours of charge needed. – juhist May 25 '17 at 13:01
2

I took it to a main dealer who diagnosed that the battery needed a replacement.

Now a quick test with the blowers doesn't seem to show any voltage loss as before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.