8

I got a 2004 sv650s Suzuki when I turn the key on the fuel pump does not come on and the CHECK light comes on on the dash. All the lights come on and the starter button does not work.All the fuses are good. Any ideas thanks

  • Have you checked the fuses? Have you checked the hotlead of the fuel pump mounted in the gastank with a multimeter to see if you have power? – DucatiKiller Jan 11 '16 at 22:09
  • If you smell any gas fumes around the tank, be careful when checking those leads. – Lynn Crumbling Jan 11 '16 at 22:11
  • You can take this tour of how this stack exchange site works to if you like. youtube.com/watch?v=Ljd7f2tFOak It will give you a basic understanding of Stack Exchange. Welcome and cheers! – DucatiKiller Jan 11 '16 at 22:13
  • I flipped it over backwards does it have a fuel cutoff – Chet Jan 11 '16 at 22:13
  • You looped it? sorry to hear that. No fuel cutoff or tip over sensors on your year. – DucatiKiller Jan 11 '16 at 22:26
7

You have 4 things to check to start figuring your issue out.

  • Check your TPS

  • Pull codes

  • Check fuses

  • Check hot wire of the fuel pump with a multimeter

Pulling Suzuki Fuel System Codes or Entering Dealer Mode on a post-2001 Suzuki Motorcycle

You can put your bike into what is called 'dealer mode' to get data and information regarding what might be the issue you are having.

It's relatively limited when compared to OBDII but sometimes you can get some excellent troubleshooting breadcrumbs by doing this.

Beneath your rear seat you will see a white connector with a rubber cover over it. There are 4 total connections and two blanks on the connector.

Here's the best pic I could find of the connector

enter image description here

Make sure your ignition is off when perform this procedure

Once you have located it you will put a wire loop between two of the connections with a bit of wire. You will connect two of the 4 active connections in the connector. The two that you want are side by side.

You are going to loop them together with a piece of wire.

enter image description here

Here is the connector wit the wire loop inserted into the two 'active' side by side connections within the white connector.

enter image description here

Now, you can turn on your ignition. Look at your dash and see if you have any codes that reveal themselves.

If you get a code c00, there are no codes.

You will see the codes in the bottom right hand corner of your display.

enter image description here

Here is the chart to identify what the codes mean.

There is a code for a TOS.

enter image description here

Correction from my comments Your model year does have a tip over sensor

This is what it looks like. It's on the front of your battery. Facing the front of your motorcycle. Ensure it's rubber slot is mounted properly to the front of your battery holder where there is a tab.

Apologies for my misinformed comment, I believed the TOS didn't arrive until 2005. Notice the up arrow stamped into it

enter image description here

If you have codes and you feel that is the issue, feel free to come back to this thread and I can add/modify additional information for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.