-1

Power cuts out when I wiggle positive battery terminal right when I wiggle it left power comes back on megane 225 please help when I put foot on accelerator it feels like I'm being g pushed backwards hard and internal light comes on :(

closed as unclear what you're asking by Rory Alsop, Pᴀᴜʟsᴛᴇʀ2, Zaid, Fred Wilson, DucatiKiller Jan 3 '16 at 21:00

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    What is your question? If it is about the terminal, then you obviously have a loose connection. If it is about the acceleration then you need to update your post to explain what the problem is – Rory Alsop Jan 3 '16 at 11:53
  • 2
    Many people will be jealous of you car's acceleration :) can you explain more? – HandyHowie Jan 3 '16 at 13:59
  • Yes indeed @HandyHowie , yes indeed. – Ppoggio Jan 5 '16 at 8:30
  • @robkershaw did you tighten the battery terminal or just notice it and move on?? – Ppoggio Jan 5 '16 at 8:30
2

Your alternator has to be checked because of the terminal wiggle. More so the vehicle is having some electrical body ground contact which causes the light to come on when not operated.

  • We want you to be here so we've helped you a little. I've edited your post to make it clearer to read. Please remember, we have an international community here where English may not be their first language. Please consider these people when you write something so that it makes sense. Using non-words, concatenation, and no punctuation doesn't help things. – Pᴀᴜʟsᴛᴇʀ2 Jan 3 '16 at 18:32
  • Whaoo!! I am new here but no problem I will dance to the tune of the community. Thanks a lot. – tomobile motors Jan 3 '16 at 18:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.