0

Hi so when I try to start my car nothing happens I even got a new battery nothing happens. Also my cars remote control has no effect on the vehicle.

Please help me what is this problem ?

2
  • 2
    Does anything work, lights, horn, radio, wipers? – HandyHowie Nov 23 '15 at 22:04
  • @HandyHowie no nothing at all – Stackz4Dayz Nov 23 '15 at 23:09
4

There is a very limited number of things that could be wrong here and all of them revolve around the battery. If the battery is new and charged and you haven't left anything on that has flattened this battery, then you have a bad connection from the battery positive to the fuse box or the battery negative to the bodywork.

Check that the battery connectors are making a good connection to the battery.

Check that the ends of the cables are securely connected in to the battery connectors.

Check the battery cables are not damaged along their length.

Check where the other end of the positive cable go into the fuse box, which shouldn't be far away, make sure it is securely connected and there is no corrosion.

Check where the other end of the negative cable connects to the bodywork, make sure it is secure and again with no corrosion.

You could loosen each of these connections and clean them before fastening them back down. If you do this, disconnect the battery negative connector during the whole procedure.

Check the fuse-able link in the fuse box and the surrounding area for signs of burning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.