0

I have a Kia just bought a battery last week. My car will not start today. No clicking sound no lights no radio my car won't even lock nothing works. What could this be?

  • 1
    Are you sure the battery connectors on your new battery are fastened on nice and tight? – HandyHowie Nov 23 '15 at 8:27
  • Are you sure the alternator is working? – Steve Matthews Nov 23 '15 at 13:09
1

Check the car for a parasitic draw. Something that draws on the battery while the car is off. It could be as simple as leaving the dome light on or as complicated as a failed module.

To check for a draw, get a fully charged battery or charge the one you have. Install the battery but do not connect the negative cable. Use a multi meter set to amps to connect the negative battery cable to the negative battery terminal. (the meter is between the two) Allow the vehicle to fully fall asleep for around an hour. A standard rule of thumb is 25mA of draw when the car is asleep.

If the draw is higher then that start pulling fuses while watching the meter. When the current drops to an acceptable level, explore the fuse that did it.

A few words of caution; when the battery is first hooked up the current draw may be high so make sure the meter you have can handle it. There are devices that allow easy connection and disconnect of a battery cable for measuring purposes. Also the meter needs to be sensitive enough to measure in milliamps.

  • The icing on the cake will be the fact that the existing battery was flat – Zaid Dec 19 '15 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.