3

I have a 2008 Scion. I changed the water pump and alternator. After I put it back together I have no power steering, power door locks or windows, Tail or brake lights. Half the warning lights on the instrument panel are lit. I checked all the fuses I know about.

Because Toyota service departments are closed on weekends I took it to O'Reilly auto parts where I tried to have them use a diagnostic tool on it. The guy looked at me baffled and said it did not recognize that it was reading a car and told me he cannot help.

Any ideas?

  • Let's not overlook the obvious: Does the belt turn when the engine cranks over? Many of the symptoms are consistent with a slipping belt. – Zaid Nov 8 '15 at 11:07
  • Also, if so equipped, did you ensure you reinstalled the ground to the alternator? Many vehicles provide a ground which attaches right at the alternator. Without it, you'll get these types of issues as well. – Pᴀᴜʟsᴛᴇʀ2 Nov 8 '15 at 11:09
  • If you just changed the alternator then it's probably what gives you a problem. Definitely check the grounds and belt. – I have no idea what I'm doing Nov 9 '15 at 10:02
  • @Zaid I have been puzzling over how this could be caused by a slipping belt, or even a missing ground off the alternator. Can you help me understand this? – HandyHowie Nov 9 '15 at 10:33
  • @HandyHowie : A slipping belt could be responsible for loss of power steering (pulley not spinning fast enough) and an undercharging alternator. The undercharging alternator may cause issues related to the electricals/electronics. If the battery isn't getting charged properly it may also explain the OP's reports of the scan tool struggling to connect; your BCM theory would tie in nicely here as well. Feel free to drop in at The Pitstop and we can discuss it further :) – Zaid Nov 9 '15 at 14:39
1

The more I think about this, the more I am thinking that it is the Body Control Module (BCM) ECU that has failed. I believe all of those functions will be controlled by the BCM. It is also probably pulling down the CAN Bus which is causing the diagnostics tool to not connect. It may have failed when reconnecting the battery, or possibly the alternator is producing too high a voltage which has damaged it.

I have been trying to find out if the car has a separate ECU for the power steering, but haven't worked it out yet. According to this website it has electric power steering, so that would fit with it being an ECU problem - http://www.edmunds.com/scion/xd/2008/features-specs/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.