1

My 2007 Mustang GT makes funny noise when starting, and lately disconnects my Clock and radio. Would that mean that I need a new starter or do I have electrical problems?

6
  • Does it eventually start?
    – Zaid
    Oct 20, 2015 at 13:44
  • @Zaid Yes it does. I also notice that it only does that after sitting for hours outside. In colder climate. Thanks
    – user36839
    Oct 20, 2015 at 13:46
  • 3
    Sounds like a bad battery, or at least a battery that needs to be charged. Most parts stores will check a battery for free if you bring it in.
    – JPhi1618
    Oct 20, 2015 at 14:03
  • I didn't think that it could be a battery issue because my gauges inside of my vehicle all shows positive with a high charge.
    – user36839
    Oct 20, 2015 at 14:10
  • 4
    The voltage isn't the only thing to test on a battery. The no-load voltage may seem ok, but when you attempt to start, the battery can't handle the load and voltage can drop to near zero, causing your clock and radio and everything else to turn off. Note that this can also be a bad connection to the battery - loose or corroded terminals.
    – JPhi1618
    Oct 20, 2015 at 14:25

1 Answer 1

1

Do the clock and radio come back on again after the car has started? If they do then I would be inclined to look at the battery and the connections. Is there any build up on the terminals? Have you tried starting the car with the headlights on and see if they dim as well?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .