3

My 98 Mazda 626 GF 2L won't start. About a week ago I was playing with the air adjust screw ( taking it from full open to almost closed ) and it wouldn't start after that, so I assumed that was the problem, reopened it and after a few tries and waiting a bit it started and ran for ten minutes before I shut it off.

After a week, tried starting it again. It started ran for a second or two, then died. Started it again and tried giving it gas, same thing happened. Now I can't get it to start at all. Thought I might be getting too much water condensing in the tank since it's been sitting with an almost empty tank in hot weather for quite a while, so I put in some IPA and an extra four liters of gas, but that so far hasn't helped. Hope I don't have water in the fuel line.

It reminds me of what happened when I disconnected the fuel pump on a different vehicle once to depressurize the fuel line before changing the fuel filter.

So I hooked up a scan tool while trying to crank it. I looked at the live PIDs while trying to crank the engine and the only ones which stood out as looking unusual where:

Live PID's:

Short term fuel % trim - Bank 1: -100%

Absolute throttle position: 10.98% ---- Min=Avg=Max

Calculated Load got up to 85% while cranking.

Just for reference to the Freeze Frame later on:

Engine coolant temperature: 80.6F

Intake air temperature: 102.2F

Long term fuel % trim - Bank 1: 0

There are also three stored DTC's, two pending ones and a freeze frame ( which I assume is related to the most recently occurring DTC ).

Stored:

P0113: Intake Air Temperature Sensor 1 Circuit High

P0118: Engine Coolant Temperature Circuit High

P1409: Mazda: Electronic vacuum regulator control - circuit malfunction

Pending:

P0122: Throttle/Pedal Position Sensor/Switch "A" Circuit Low

P1131: Mazda: Heated oxygen sensor (HO2S) lean mixture indicated

Freeze Frame ( Can there be more than one freeze frame? )

DTC: P0118
Fuel system status: Open-loop due to insufficient engine temperature
Calculated load value: 15.29%
Engine coolant temperature: -40F
Short term fuel % trim - Bank 1: 24.22%
Long term fuel % trim - Bank 1: 0
Engine RPM: 2544.5
Vehicle speed: 0

Discussion:

I verified there is a small vacuum leak from the number 3 lower injector seal, but it's not new and I don't think it's the cause of this problem.

Coolant temp sensor was disconnected for a while while locating a coolant leak, and I've also started the engine with some vacuum lines disconnected once or twice.

The only things I don't think I can explain away are the TPS reading and the short term fuel trim. I'm not sure about why the load got so high during cranking and if that's normal or not.

I took the throttle body off and cleaned it a few weeks ago, and last time I looked it was fully closing, although I guess it's possible it recently got stuck open a bit somehow.

Should I try resetting the ECU or clearing all codes and trying again to see what happens?

What should my next step be?

EDIT1

After resetting all the DTCs the P1409 code went from stored to pending, and I still can't start the engine. I hooked up the ForScan software which gives access to the ECU built in self tests and ran all I could. Another code came up, P1624 - Immobilizer communication count = 0, but I think that's OK as the previous owner disabled the immobilizer. Other than those two dtc's everything supported came up normal including the fuel system.

For P1409 Forscan shows ( EVR = Electronic Vacuum Regulator ):

===PCM DTC P1409===
Code: P1409 - EVR circuit fault
Module: Powertrain Control Module
Diagnostic Trouble Code details
EVR circuit fault
This DTC may be caused by :
Suspect EVR solenoid.
Open EVR circuit.
Shorted EVR circuit.
Shorted EVR wiring harness.
Suspect PCM.
===END PCM DTC P1409===

I've found some posts which point to this being an EGR code, which is funny because I recently checked the voltages on the EGR pins and they seemed to be in spec (23.7 ohms @ 90F).

I wonder if this has anything to do with my recent Seafoaming of the intake. I've heard this can uncover problems with the EGR, although I'm not sure how.

Maybe the EGR is stuck open and that's why it won't start?

EDIT2

Turned out the EGR solinoid was just unplugged, so I plugged it back in, but it still won't start and now when I try to connect to the ECU it fails with CAN ERROR: 3 ( 8.1% ), whatever that means.

  • I don't know exactly what to tell you, but start by clearing the codes and trying again (maybe you did this) to see what is recurring. Also, check your fuel pressure at the rail to ensure you are building pressure. You can also squirt a little bit of carb cleaner in the intake to see if it will fire briefly. If it does, you can narrow it down to a fuel issues (not getting enough/any to start). Let me know what you figure out. Also, while not causing any real issues to allow it to run, the vacuum leak will cause things to not run well. Getting it fixed will only help. Get 'er done. – Pᴀᴜʟsᴛᴇʀ2 Oct 16 '15 at 20:03
  • @Paulster2 Apparently P1409 is an EGR solenoid code. See my edits. – Robert S. Barnes Oct 18 '15 at 8:04
  • Is the throttle drive-by-cable or drive-by-wire? Clearly the engine refuses to start because the air-fuel mixture is all wrong (the O2 seems to think you're running too lean, and the short term fuel trims appear to confirm this (though I question the applicability of trusting any O2 sensor reading during cranking - the sensor will not have had enough time to heat up) – Zaid Oct 18 '15 at 8:50
  • Are you sure the air adjust screw was fully open to begin with? – Zaid Oct 18 '15 at 8:57
  • @Paulster2 Turned out the EGR solinoid was just unplugged, so I plugged it back in, but it still won't start and now when I try to connect to the ECU it fails with CAN ERROR: 3 ( 8.1% ), whatever that means. – Robert S. Barnes Oct 20 '15 at 11:46
2

After resetting the ECU by leaving the battery unplugged over night and trying to start the car again, the ForScan software picked up a P1602 code, which is a different immobilizer code:

Wiring, incorrect key, immobilizer control module, ECM

The previous owner told me there was a problem with one of the keys, but that the immobilizer was disabled.

Apparently, it wasn't. I tried the other key and the car started immediately.

  • Now why didn't I think of that? :) – Zaid Oct 21 '15 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.