1

Even if I have the fan set to off and the temperature dial set all the way to cold, extremely hot air is coming from my vents into the cabin. It seems to get worse at higher speeds.

If I turn the A/C on, I get cold air, so that is working. But when the fan is set to off there should not be any hot air coming in.

This might be the problem, but I'm not 100% sure:

http://www.xkjeeps.com/tsb/tsb_xk_2400207.pdf

  • I am having the same problem on a 2006 Jeep Commander. Rob - how did you eventually fix your problem. Thank you in advance. Mark G – Mark G Mar 30 '16 at 18:33
  • @MarkG It turned out my water pump needed to be replaced. Had to do this 3 times over the lifetime of my Jeep (175K miles). – Rob Sobers Apr 3 '16 at 18:35
3

With the a/c off, the air coming into the cabin should be at outside temperatures unless something under the bonnet is heating it up. If your engine is running at correct speeds I'd be tempted to look at the airflow path and see if a hose is running along a radiator or resting on one of the hotter bits of the engine.

Or is your cabin heater switch broken? Perhaps it is stuck in the on position, no matter where your dial is turned to.

  • 1
    Or a bad thermostat - it's not clear how smart the temperature controls are trying to be. – Bob Cross Oct 10 '11 at 13:53
  • At times, even when at a full stop, there's hot air blowing from the vents. This is with the fan in the off position and the temperature gauge all the way on cool. – Rob Sobers Oct 13 '11 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.