1

Speedometer stop working on My Opel corsa C 2006, it always shows 0 km/h although I am driving the car, before it stop working it vibrated some times and then stopped.
Does it have a specific Fuse in Fuse box, or a cable to the panel?
please help
Note: The light in background working good
enter image description here

  • Note: this is an example image not real image – JustMe Aug 21 '15 at 16:42
  • Please tell me which fuse was it??? Thanks – user21849 Aug 23 '16 at 20:21
2

If the rest of the gauges in your dash are working, the problem is most likely the speed sensor which is located in the transmission. This is most likely a Hall effect sensor which reads a reluctor wheel attached to the final drive. It relates the amount of times per second the reluctor is tripped and transmits this back to PCM for interpretation. The PCM then tells the speedometer where to point the needle at so you can understand your speed.

EDIT: It appears that your Opel may be using one of the wheel sensors as the speed sensor. It is still the same basic issue, just in a different location.

  • I rule out the possibility that the problem is in the sensors, because the problem appeared in the same time as problems appeared in fuse box – JustMe Aug 22 '15 at 2:02
  • @JustMe what problems appeared in the fuse box? It may be important information to help us understand/diagnose what could be the problem – Zaid Aug 22 '15 at 3:39
1

I solved the problem by change some fuses on my Fuse box, now the Speedometer is working good, Thanks to every one try to help me

Not the answer you're looking for? Browse other questions tagged or ask your own question.